summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD15
1 files changed, 14 insertions, 1 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 81a9f1ac0..4fc4bce5f 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -50,16 +50,18 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
iceweasel-install-dir.patch
vendor.js
shared-libs.patch
+ replace-urls.txt
Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch)
md5sums=('0a7c51bb494463c327af918bae6c4ee4'
'c17121a4ffd40f463e16d7828445d96e'
'e1e903ca91997f18b428c54ef604f27d'
'383e8e2a97a8b13fe56d153adb6878b6'
- '53ad37c06fd7c7364cb276588964449d'
+ 'cf0362e30fed1c29b3cb09691e5212d3'
'7b9e5996dd9fe0b186a43a297db1c6b5'
'abf5ecb74caa857abb42bcfbb3442d9c'
'0c26941504d3f2abed759221e9bb5de1'
'52e52f840a49eb1d14be1c0065b03a93'
+ 'a8fc4658d45b6bf9350023e5c3f34e56'
'85e67561e0e491cd538ce018dfc2d948')
prepare() {
@@ -84,6 +86,17 @@ prepare() {
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
patch -Np1 -i "$srcdir/shared-libs.patch"
+ # Replace common URLs
+ sed '/^#/d' ../replace-urls.txt | while read -r moz_url gnu_url; do
+ if [[ -n $moz_url ]]; then
+ printf 'liberating: %s -> %s\n' "$moz_url" "$gnu_url"
+ grep -Erl "${moz_url}" \
+ --exclude='*.'{patch,orig,rej} \
+ --exclude-dir={.pc,test,tests,testing} \
+ | xargs -d '\n' --no-run-if-empty sed -ri "s<${moz_url}<${gnu_url}<g"
+ fi
+ done
+
# Patch anything that's left
patch -Np1 -i "$srcdir/libre.patch"