summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD57
1 files changed, 31 insertions, 26 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 1fafebea5..3a2fcaa9f 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
-# Contributor (Parabola): Márcio Silva <coadde@parabola.nu>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+# Contributor: Márcio Silva <coadde@parabola.nu>
# Contributor (ConnochaetOS): Henry Jensen <hjensen@connochaetos.org>
-# Contributor (Parabola): Luke Shumaker <lukeshu@sbcglobal.net>
-# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
-# Contributor (Parabola): vando <facundo@esdebian.org>
+# Contributor: Luke Shumaker <lukeshu@sbcglobal.net>
+# Contributor: fauno <fauno@kiwwwi.com.ar>
+# Contributor: vando <facundo@esdebian.org>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
# Contributor: Figue <ffigue at gmail>
# Thank you very much to the older contributors:
@@ -12,9 +12,9 @@
_pgo=true
-# We're getting this from Debian Experimental
+# We're getting this from Debian Sid
_debname=iceweasel
-_debver=28.0
+_debver=29.0.1
_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -23,13 +23,13 @@ _pkgname=iceweasel
pkgname=iceweasel-libre
epoch=1
pkgver=$_debver.$_debrel
-pkgrel=1
+pkgrel=2
pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 mips64el)
license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
-makedepends=(autoconf2.13 diffutils gstreamer0.10-base imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
+depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell icu libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
+makedepends=(autoconf2.13 clang diffutils gstreamer0.10-base imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
[ "$CARCH" != "mips64el" ] && makedepends+=('yasm')
options=(!emptydirs !makeflags)
if $_pgo; then
@@ -43,7 +43,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'gstreamer0.10-ugly-plugins: h.264 and mp3 decoding'
'gstreamer0.10-ffmpeg: more decoders'
'libpulse: PulseAudio audio driver')
-url="http://packages.debian.org/experimental/${_pkgname}"
+url="http://packages.debian.org/sid/${_pkgname}"
install=iceweasel.install
replaces=('firefox')
conflicts=('firefox')
@@ -60,17 +60,17 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
iceweasel-20.0.1-fixed-loading-icon.png
Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
Fixup-Reset-Firefox-after-bad-merge.patch)
-md5sums=('8b53f3d7c1eea0338408f743f619eec1'
- 'e5399fd8ea49c227b9a4c45997dc7111'
- '023120a970670dc85cea19393f0b94b6'
+md5sums=('4db358c753cb15a526dfe79c6602c886'
+ '134a1bfe72a940ec6673ee6883a03b68'
+ '92a08a18995b915d6a6d0dab93ec6c1d'
'df08eaa1ac3bc6c2356be4fbf8ec8932'
'5d22063ebea2472dd0b1163b32b2050b'
'b03a979a78484503ba8dddad4f2c96d1'
'7b9e5996dd9fe0b186a43a297db1c6b5'
- '6620e724ec9a1be74e65089d81d802f7'
- '816013881cfc9a1f4f0ede72b014f8b3'
+ '1c42509891cf6843660a5f3c69896e80'
+ '783a5927246f014855b96a3abb92566b'
'6e335a517c68488941340ee1c23f97b0'
- '032553b17a61a9a79c7a03c8967251b2'
+ '9d1cc7b80085a4438305e9e37d42745b'
'8e165ef85ddd72491f0b48f8954afca6')
prepare() {
@@ -105,6 +105,11 @@ prepare() {
sed -i 's|Adobe Flash|SWF Player|g;
' browser/base/content/pageinfo/permissions.js \
browser/base/content/browser-plugins.js
+ sed -i '\|["]displayName["][:] ["]Flash["]| s|Flash|SWF Player|
+ \|["]displayName["][:] ["]Shockwave["]| s|Shockwave|DCR Player|
+ \|["]displayName["][:] ["]QuickTime["]| s|QuickTime|MOV Player|
+ \|installLinux| s|true|false|
+ ' browser/base/content/browser-plugins.js
sed -i '\|URL of the GeoLocation backend|d;
\|geo[.]wifi[.]uri|d;
' browser/app/profile/firefox.js \
@@ -113,11 +118,12 @@ prepare() {
sed -i "\|abouthome/snippet|d" browser/base/jar.mn
# Replace common URLs
- sed -i '\|extensions[.]getAddons[.]get[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|http://directory.fsf.org/wiki/GNU_IceCat");|g;
- \|extensions[.]getAddons[.]search[.]browseURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|http://directory.fsf.org/wiki/GNU_IceCat");|g;
- \|extensions[.]getAddons[.]search[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|http://directory.fsf.org/wiki/GNU_IceCat");|g;
- \|extensions[.]webservice[.]discoverURL| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|http://directory.fsf.org/wiki/GNU_IceCat");|g;
- \|browser[.]search[.]searchEnginesURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|http://directory.fsf.org/wiki/GNU_IceCat");|g;
+ sed -i '\|extensions[.]getAddons[.]get[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|extensions[.]getAddons[.]search[.]browseURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|extensions[.]getAddons[.]search[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|extensions[.]webservice[.]discoverURL| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|browser[.]search[.]searchEnginesURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|plugins[.]update[.]url| s|https://www[.]mozilla[.]org/[%]LOCALE[%]/plugincheck/["][)][;]|https://trisquel.info/en/browser");|g;
' browser/app/profile/firefox.js
cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
@@ -180,6 +186,8 @@ build() {
export PATH="$srcdir/path:$PATH"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$_pkgname"
export PYTHON="/usr/bin/python2"
+ export CC=clang
+ export CXX=clang++
if [[ $CARCH == i686 ]]; then
# Work around memory address space exhaustion during linking on i686
@@ -206,7 +214,7 @@ package() {
export DEBIAN_BUILD="mozilla-release"
cd "$srcdir/$DEBIAN_BUILD"
- make -f client.mk DESTDIR="$pkgdir" install
+ make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
install -Dm644 ../vendor.js "$pkgdir/usr/lib/$_pkgname/browser/defaults/preferences/vendor.js"
@@ -231,9 +239,6 @@ package() {
ln -sf /usr/lib/mozilla/plugins "$pkgdir/usr/lib/$_pkgname/browser/plugins"
ln -sf /usr/lib/mozilla/searchplugins "$pkgdir/usr/lib/$_pkgname/browser/searchplugins"
- # We don't want the development stuff
- rm -rf "$pkgdir"/usr/{include,lib/$_pkgname-devel,share/idl}
-
# Workaround for now: https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -sf $_pkgname "$pkgdir/usr/lib/$_pkgname/$_pkgname-bin"
}