summaryrefslogtreecommitdiff
path: root/libre/iceweasel-l10n/PKGBUILD.in
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel-l10n/PKGBUILD.in')
-rw-r--r--libre/iceweasel-l10n/PKGBUILD.in23
1 files changed, 20 insertions, 3 deletions
diff --git a/libre/iceweasel-l10n/PKGBUILD.in b/libre/iceweasel-l10n/PKGBUILD.in
index 05477caef..7dd82c7cc 100644
--- a/libre/iceweasel-l10n/PKGBUILD.in
+++ b/libre/iceweasel-l10n/PKGBUILD.in
@@ -16,7 +16,7 @@ debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
_langpacks=@LANGPACKS@
-pkgbase=iceweasel-i18n
+pkgbase=iceweasel-l10n
pkgname=($(for lang in ${_langpacks[@]}
do echo $pkgbase-$lang | tr A-Z a-z
done))
@@ -36,6 +36,8 @@ noextract=($(for lang in ${_langpacks[@]}
do echo $lang.xpi
done))
+_path="/usr/lib/iceweasel-${_pkgver}/extensions"
+
dpkg-source() {
# This will simulate dpkg-source -x ${_debname}_${_debver}-${_debrel}.dsc
cd "${_debname}-${_debver}"
@@ -46,16 +48,31 @@ dpkg-source() {
build() {
cd "${srcdir}"
dpkg-source -x ${_debname}_${_debver}-${_debrel}.dsc
+
+cd $srcdir$_path
+
+for i in ${_langpacks[@]}
+do
+ unzip -q langpack-$i@iceweasel.mozilla.org.xpi -d $i
+ rm langpack-$i@iceweasel.mozilla.org.xpi
+ install -Dm644 $srcdir/region.properties $i/chrome/$i/locale/browser-region
+ zip -q -r langpack-$i@iceweasel.mozilla.org.xpi $i
+done
+
+cd $srcdir
}
-_path="/usr/lib/iceweasel-${_pkgver}/extensions"
+
# CUT HERE <-- Separates package_*() functions from everything else.
for lang in ${_langpacks[@]}
do
eval "
-package_iceweasel-i18n-$(echo $lang | tr A-Z a-z) () {
+package_iceweasel-l10n-$(echo $lang | tr A-Z a-z) () {
+ replaces=(icedove-i18n-$(echo $lang | tr A-Z a-z))
+ conflicts=(icedove-i18n-$(echo $lang | tr A-Z a-z))
+ provides=(icedove-i18n-$(echo $lang | tr A-Z a-z))
install -Dm644 '$srcdir/'*'/upstream/$lang.xpi' \"\$pkgdir\"'$_path/langpack-$lang@firefox.mozilla.org.xpi'
}
"