summaryrefslogtreecommitdiff
path: root/libre/icedove/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/icedove/PKGBUILD')
-rw-r--r--libre/icedove/PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/libre/icedove/PKGBUILD b/libre/icedove/PKGBUILD
index 7af854a32..edbf18bf1 100644
--- a/libre/icedove/PKGBUILD
+++ b/libre/icedove/PKGBUILD
@@ -33,10 +33,13 @@ arch=(x86_64)
arch+=(i686 armv7h)
license=(MPL GPL LGPL)
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
- nss hunspell sqlite ttf-font icu) # libvpx
-depends+=(icu-parabola libicudata.so=67)
+ nss hunspell sqlite ttf-font) # libvpx
+depends_armv7h=(libicudata.so=67-64)
+depends_i686=(icu=65.1) # TODO: depends_i686=(libicudata.so=67-32)
+depends_x86_64=(libicudata.so=67-64)
+makedepends_i686=(rust=1:1.42.0) # TODO: this is currently in [staging]
makedepends=(unzip zip diffutils python python2 yasm nasm mesa imake libpulse inetutils xorg-server-xvfb
- autoconf2.13 rust clang llvm gtk2 cbindgen nodejs)
+ autoconf2.13 rust clang llvm gtk2 cbindgen nodejs icu)
makedepends+=(quilt mozilla-searchplugins imagemagick)
optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags)