summaryrefslogtreecommitdiff
path: root/libre/icedove-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/icedove-libre/PKGBUILD')
-rw-r--r--libre/icedove-libre/PKGBUILD31
1 files changed, 14 insertions, 17 deletions
diff --git a/libre/icedove-libre/PKGBUILD b/libre/icedove-libre/PKGBUILD
index 18e394f61..fe880d03d 100644
--- a/libre/icedove-libre/PKGBUILD
+++ b/libre/icedove-libre/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer : Márcio Silva <coadde@lavabit.com>
# Maintainer : André Silva <emulatorman@parabola.nu>
-# We're getting this from Debian Sid
+# We're getting this from Debian Experimental
_debname=icedove
-_debver=17.0.9
-_debrel=deb2
+_debver=24.0
+_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -16,7 +16,7 @@ pkgrel=1
pkgdesc="A libre version of Debian Icedove, the standalone mail/news reader based on Mozilla Thunderbird."
arch=('i686' 'x86_64' 'mips64el')
license=('MPL' 'GPL' 'LGPL')
-url="http://packages.debian.org/sid/${_pkgname}"
+url="http://packages.debian.org/experimental/${_pkgname}"
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'mozilla-searchplugins' 'nss' 'sqlite' 'startup-notification')
makedepends=('unzip-libre' 'zip' 'pkg-config' 'python2' 'python2-virtualenv' 'wireless_tools' 'yasm' 'mesa' 'autoconf2.13' 'quilt')
optdepends=('libcanberra: for sound support')
@@ -24,22 +24,22 @@ replaces=('thunderbird')
conflicts=('thunderbird')
provides=('thunderbird')
install=${_pkgname}.install
-source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
+source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.xz"
"${_debrepo}/`debfile ${_debname}`_${_debver}-${_debrel#deb}.debian.tar.gz"
mozconfig
replace-urls.txt
vendor.js
${_pkgname}.desktop)
options=(!emptydirs)
-md5sums=('4c2aacece253be8f177a74d90d782f45'
- 'dd8ccad23583cc0d8c3b77066711f077'
- '5cf95ea94f69cdd36604890cfbf7b954'
- 'a8fc4658d45b6bf9350023e5c3f34e56'
- '4eecc4fc5aafaf0da651a09eadc90bee'
+md5sums=('c69b05c9a1c28d455964aed4927ef916'
+ 'c67dc2f46f0e4d463ebe1ccdbfae6392'
+ '5bd3b5b1c79d87d2720252e9b06ba09e'
+ 'e14242e651928bd658ec8d489088b6f2'
+ '5a53179d14ae9631b7afe5e4d0fc0b25'
'e785e0c267f4435ae1a9aa0b03bcacfb')
prepare() {
- export DEBIAN_BUILD="comm-esr17"
+ export DEBIAN_BUILD="comm-esr24"
export QUILT_PATCHES=debian/patches
export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
@@ -92,14 +92,11 @@ prepare() {
# configure script misdetects the preprocessor without an optimization level
# https://bugs.archlinux.org/task/34644
- sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
-
- # Fix virtualenv path
- sed -i 's|/usr/share/pyshared/virtualenv.py|/usr/lib/python2.7/site-packages/virtualenv.py|' mozilla/configure
+ sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' mozilla/configure
}
build() {
- export DEBIAN_BUILD="comm-esr17"
+ export DEBIAN_BUILD="comm-esr24"
cd "${srcdir}/${DEBIAN_BUILD}"
@@ -110,7 +107,7 @@ build() {
}
package() {
- export DEBIAN_BUILD="comm-esr17"
+ export DEBIAN_BUILD="comm-esr24"
cd "${srcdir}/${DEBIAN_BUILD}"