summaryrefslogtreecommitdiff
path: root/libre/handbrake/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/handbrake/PKGBUILD')
-rw-r--r--libre/handbrake/PKGBUILD51
1 files changed, 28 insertions, 23 deletions
diff --git a/libre/handbrake/PKGBUILD b/libre/handbrake/PKGBUILD
index e3e5a6732..e4e2baabe 100644
--- a/libre/handbrake/PKGBUILD
+++ b/libre/handbrake/PKGBUILD
@@ -1,31 +1,33 @@
-# $Id$
# Maintainer (Arch): Evangelos Foutras <evangelos@foutrelis.com>
# Contributor (Arch): Giovanni Scafora <giovanni@archlinux.org>
# Contributor (Arch): Sebastien Piccand <sebcactus gmail com>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=('handbrake' 'handbrake-cli')
-pkgver=1.1.0
-pkgrel=1.parabola1
-arch=('i686' 'x86_64' 'armv7h')
+pkgver=1.1.2
+pkgrel=1
+pkgrel+=.par1
+arch=('x86_64')
+arch+=('i686' 'armv7h')
url="https://handbrake.fr/"
license=('GPL')
-makedepends=('intltool' 'python2' 'yasm' 'wget' 'bzip2' 'gcc-libs' 'libnotify'
- 'gst-plugins-base' 'gtk3' 'dbus-glib' 'fribidi' 'libass' 'lame'
- 'fontconfig' 'freetype2' 'libxml2' 'libogg' 'libvorbis' 'cmake'
- 'libtheora' 'libsamplerate' 'ffmpeg' 'x264' 'libx264' 'x265'
- 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev'
- 'libdvdread' 'libbluray')
+makedepends=('intltool' 'python2' 'yasm' 'wget' 'cmake' 'bzip2' 'gcc-libs'
+ 'zlib' 'libnotify' 'gst-plugins-base' 'gtk3' 'dbus-glib' 'libass'
+ 'lame' 'libxml2' 'opus' 'libvorbis' 'libtheora' 'libsamplerate'
+ 'x264' 'jansson' 'librsvg' 'libgudev')
+makedepends+=('ffmpeg' 'libdvdnav')
source=(https://download.handbrake.fr/releases/$pkgver/HandBrake-$pkgver-source.tar.bz2
https://github.com/HandBrake/HandBrake/releases/download/$pkgver/HandBrake-$pkgver-source.tar.bz2.sig
handbrake-fix-missing-x265-link-flag.patch
handbrake-no-download.patch
- handbrake-supress-clip_id.patch)
-sha256sums=('a02e7c6f8bd8dc28eea4623663deb5971dcbca1ad59da9eb74aceb481d8c40da'
+ handbrake-supress-clip_id.patch
+ switch-libav-to-ffmpeg.patch)
+sha256sums=('ba9a4a90a7657720f04e4ba0a2880ed055be3bd855e99c0c13af944c3904de2e'
'SKIP'
'05e212e76b6e0b94a04de02cbeb7bf9db607059e19297b5bd3d0d143135285c4'
'd8116caa83f870803581f0d02e1302b3b8990479d446e4c73bedd35bed531042'
- '6407a96c59baa030a4e5fa46c53ddb3e841c7d4787613d391e032a62600d527f')
+ '6407a96c59baa030a4e5fa46c53ddb3e841c7d4787613d391e032a62600d527f'
+ '7f82adce83d41552e19cdd74268db4084190f201be549b45802817f80fbc37bb')
validpgpkeys+=('1629C061B3DDE7EB4AE34B81021DB8B44E4A8645') # HandBrake Team <developers@handbrake.fr>
prepare() {
@@ -33,8 +35,10 @@ prepare() {
# https://bugs.gentoo.org/show_bug.cgi?id=552792
patch -Np1 -i ../handbrake-fix-missing-x265-link-flag.patch
+
patch -Np1 -i ../handbrake-no-download.patch
patch -Np1 -i ../handbrake-supress-clip_id.patch
+ patch -Np1 -i ../switch-libav-to-ffmpeg.patch
# Use more system libs
# Bundled libbluray is kept because it is patched locally
@@ -46,21 +50,21 @@ prepare() {
build() {
cd "$srcdir/HandBrake-$pkgver"
- ./configure \
- --prefix=/usr \
+ ./configure --prefix=/usr \
--disable-gtk-update-checks
make -C build
}
package_handbrake() {
pkgdesc="Multithreaded video transcoder"
- depends=('bzip2' 'gcc-libs' 'gst-plugins-base' 'libnotify' 'dbus-glib'
- 'fribidi' 'libass' 'lame' 'gtk3' 'fontconfig' 'freetype2' 'libxml2'
- 'libogg' 'libvorbis' 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264'
- 'x265' 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev'
+ depends=('bzip2' 'gcc-libs' 'zlib' 'gst-plugins-base' 'libnotify' 'dbus-glib'
+ 'gtk3' 'libass' 'lame' 'libxml2' 'opus' 'libvorbis' 'libtheora'
+ 'libsamplerate' 'x264' 'jansson' 'librsvg' 'libgudev'
'desktop-file-utils' 'hicolor-icon-theme')
+ depends+=('ffmpeg' 'libdvdnav')
optdepends=('gst-plugins-good: for video previews'
- 'gst-libav: for video previews')
+ 'gst-libav: for video previews'
+ 'libdvdcss: for decoding encrypted DVDs')
cd "$srcdir/HandBrake-$pkgver/build"
@@ -70,9 +74,10 @@ package_handbrake() {
package_handbrake-cli() {
pkgdesc="Multithreaded video transcoder (CLI)"
- depends=('bzip2' 'gcc-libs' 'zlib' 'fribidi' 'libass' 'lame' 'libxml2'
- 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264' 'x265' 'libvpx'
- 'libdvdnav' 'jansson')
+ depends=('bzip2' 'gcc-libs' 'zlib' 'libass' 'lame' 'libxml2' 'opus'
+ 'libvorbis' 'libtheora' 'libsamplerate' 'x264' 'jansson')
+ depends+=('ffmpeg' 'libdvdnav')
+ optdepends=('libdvdcss: for decoding encrypted DVDs')
cd "$srcdir/HandBrake-$pkgver/build"
install -D HandBrakeCLI "$pkgdir/usr/bin/HandBrakeCLI"