summaryrefslogtreecommitdiff
path: root/libre/gummiboot/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/gummiboot/PKGBUILD')
-rw-r--r--libre/gummiboot/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/libre/gummiboot/PKGBUILD b/libre/gummiboot/PKGBUILD
new file mode 100644
index 000000000..018326c57
--- /dev/null
+++ b/libre/gummiboot/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 212780 2014-05-15 06:02:26Z tpowa $
+# Maintainer (Arch): Tom Gundersen <teg@jklm.no>
+# Contributor (Arch): Tobias Powalowski <tpowa@archlinux.org>
+# Contributor (Arch): Keshav P R <(the.ridikulus.rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+# Contributor (Arch): Mantas Mikulėnas <grawity@gmail.com>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+pkgname=gummiboot
+pkgver=45
+pkgrel=1.parabola1
+pkgdesc="Simple UEFI Boot Manager (Parabola rebranded)"
+url="http://freedesktop.org/wiki/Software/gummiboot"
+arch=('x86_64' 'i686' 'mips64el')
+license=('LGPL2.1')
+makedepends=('gnu-efi-libs' 'docbook-xsl' 'git')
+depends=('util-linux')
+replaces=('gummiboot-efi' "${pkgname}-parabola")
+conflicts=('gummiboot-efi' "${pkgname}-parabola")
+provides=('gummiboot-efi')
+options=('!strip' '!makeflags')
+source=("git://anongit.freedesktop.org/$pkgname#tag=$pkgver"
+ 'loader.conf'
+ 'parabola.conf'
+ 'splash-parabola.bmp')
+install=gummiboot.install
+md5sums=('SKIP'
+ '3d700d13aec5ab1b78a921eaf22e5bfa'
+ '36ee74767ac8734dede1cbd0f4f275d7'
+ 'c146ea0e16fff867164e113c48c91fff')
+
+build() {
+ cd ${srcdir}/${pkgname}
+
+ ./autogen.sh
+ ./configure --sysconfdir=/etc --with-efi-ldsdir=/usr/lib --libexecdir=/usr/lib --libdir=/usr/lib
+
+ make
+}
+
+package() {
+ ## Install gummiboot example configuration files (can go away with systemd's kernel-install)
+ install -D -m0644 "${srcdir}/loader.conf" "${pkgdir}/usr/lib/gummiboot/loader/loader.conf"
+ install -D -m0644 "${srcdir}/parabola.conf" "${pkgdir}/usr/lib/gummiboot/loader/entries/parabola.conf"
+
+ ## ship an Parabola GNU/Linux-libre boot splash (still has to be dropped in manually to take effect)
+ install -D -m0644 "${srcdir}/splash-parabola.bmp" "${pkgdir}/usr/lib/gummiboot/splash-parabola.bmp"
+
+ cd ${srcdir}/${pkgname}
+
+ make DESTDIR="${pkgdir}" install
+}