summaryrefslogtreecommitdiff
path: root/libre/gst-plugins-bad/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/gst-plugins-bad/PKGBUILD')
-rw-r--r--libre/gst-plugins-bad/PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/libre/gst-plugins-bad/PKGBUILD b/libre/gst-plugins-bad/PKGBUILD
index 355123007..62ab6fb17 100644
--- a/libre/gst-plugins-bad/PKGBUILD
+++ b/libre/gst-plugins-bad/PKGBUILD
@@ -6,8 +6,8 @@
# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
pkgname=gst-plugins-bad
-pkgver=1.14.1
-pkgrel=2.parabola1
+pkgver=1.14.12
+pkgrel=1.parabola1
pkgdesc="GStreamer Multimedia Framework Bad Plugins, without nonfree faac support"
url="https://gstreamer.freedesktop.org/"
arch=(i686 x86_64 armv7h)
@@ -16,16 +16,18 @@ depends=(mjpegtools gst-plugins-base-libs curl chromaprint libmms faad2 celt lib
libmodplug libgme wayland libofa openjpeg2 libwebp libsrtp gnutls sbc rtmpdump libgudev
libexif libdvdread libvdpau libmpeg2 wildmidi ladspa openal libusb vulkan-icd-loader
libfdk-aac soundtouch spandsp neon webrtc-audio-processing libdc1394 libmpcdec zvbi
- openexr libbs2b libnice lcms2 bluez-libs glu srt)
+ openexr libbs2b libnice lcms2 bluez-libs glu srt aom)
makedepends=(python gtk-doc autoconf-archive git gobject-introspection gtk3 vulkan-headers
vulkan-validation-layers librsvg libtiger zbar fluidsynth lilv opencv)
replaces=("${pkgname}-libre" "${pkgname}-parabola")
conflicts=("${pkgname}-libre" "${pkgname}-parabola")
-_commit=fd178617d0fc3bed781d566def792f90d7825d01 # tags/1.14.1^0
+_commit=513ef5efdf85f9af4a016e8ae69f28cf16c9ec58 # tags/1.14.2^0
source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-bad#commit=$_commit"
- "gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
+ "gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common"
+ missing-includes.diff)
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'acf625d58611372532bc76e7276dacd69d2a9f7dee88ed9e2e8ecae0881476a3')
pkgver() {
cd $pkgname
@@ -35,6 +37,9 @@ pkgver() {
prepare() {
cd $pkgname
+ # error: ‘CV_RGB’ was not declared in this scope
+ patch -Np1 -i ../missing-includes.diff
+
git submodule init
git config --local submodule.common.url "$srcdir/gst-common"
git submodule update