summaryrefslogtreecommitdiff
path: root/libre/filesystem/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/filesystem/PKGBUILD')
-rw-r--r--libre/filesystem/PKGBUILD24
1 files changed, 19 insertions, 5 deletions
diff --git a/libre/filesystem/PKGBUILD b/libre/filesystem/PKGBUILD
index add2fa659..49e837e02 100644
--- a/libre/filesystem/PKGBUILD
+++ b/libre/filesystem/PKGBUILD
@@ -1,24 +1,31 @@
-# $Id: PKGBUILD 163827 2012-07-20 23:47:38Z tomegun $
+# $Id: PKGBUILD 165634 2012-08-27 20:15:48Z tomegun $
# Maintainer: Tom Gundersen <teg@jklm.no>
# Maintainer (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
pkgname=filesystem
-pkgver=2012.7
-pkgrel=1
+pkgver=2012.8
+pkgrel=1.2
pkgdesc='Base filesystem for Parabola'
arch=('any')
license=('GPL')
url='https://parabolagnulinux.org'
groups=('base')
install='filesystem.install'
+makedepends=('asciidoc')
depends=('iana-etc' 'bash' 'coreutils')
backup=('etc/fstab' 'etc/crypttab' 'etc/group' 'etc/hosts' 'etc/ld.so.conf' 'etc/passwd'
'etc/shadow' 'etc/gshadow' 'etc/resolv.conf' 'etc/motd' 'etc/nsswitch.conf'
'etc/shells' 'etc/host.conf' 'etc/securetty' 'etc/profile' 'etc/issue')
source=('group' 'issue' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
'passwd' 'shadow' 'fstab' 'crypttab' 'hosts' 'motd' 'os-release' 'resolv.conf'
- 'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first')
+ 'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first' 'parabola.7.txt'
+ 'locale.sh')
+
+build() {
+ cd ${srcdir}
+ a2x -d manpage -f manpage parabola.7.txt
+}
package() {
cd ${pkgdir}
@@ -47,6 +54,7 @@ package() {
done
touch etc/arch-release
install -D -m644 ${srcdir}/modprobe.d.usb-load-ehci-first usr/lib/modprobe.d/usb-load-ehci-first.conf
+ install -m755 ${srcdir}/locale.sh etc/profile.d/locale.sh
# setup /var
for d in cache/man local opt log/old lib/misc empty; do
@@ -69,6 +77,10 @@ package() {
install -d -m755 usr/share/man/man${d}
done
+ #
+ # install parabola(7) manpage
+ #
+ install -D -m644 ${srcdir}/parabola.7 usr/share/man/man7/parabola.7
#
# setup /usr/local hierarchy
@@ -95,4 +107,6 @@ md5sums=('45940618da782cc391c59f88ab3333c3'
'22518e922891f9359f971f4f5b4e793c'
'f95416882cef800edef08382a1176b7d'
'f3b6ae7db8adffaaa4bffc6099dcbd50'
- 'a8a962370cd0128465d514e6a1f74130')
+ 'a8a962370cd0128465d514e6a1f74130'
+ '3674fcb22044d2946934e7826aa0c632'
+ '3807d07215d9116331fe1cf8feeaa0f8')