summaryrefslogtreecommitdiff
path: root/libre/evince-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/evince-libre/PKGBUILD')
-rw-r--r--libre/evince-libre/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/libre/evince-libre/PKGBUILD b/libre/evince-libre/PKGBUILD
new file mode 100644
index 000000000..d63bd54d9
--- /dev/null
+++ b/libre/evince-libre/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 210357 2014-04-14 17:00:49Z jgc $
+# Maintainer (Arch): Jan de Groot <jgc@archlinux.org>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+_pkgname=evince
+pkgname=evince-libre
+pkgver=3.12.1
+pkgrel=1
+pkgdesc="Document viewer (PDF, Postscript, djvu, tiff, dvi, XPS, SyncTex support with gedit, comics books (cbr,cbz,cb7 and cbt)), with libarchive support"
+url="https://wiki.gnome.org/Apps/Evince"
+arch=(i686 x86_64 mips64el)
+license=(GPL)
+replaces=($_pkgname)
+conflicts=($_pkgname)
+provides=($_pkgname=$pkgver)
+depends=(gtk3 libgxps libspectre gsfonts poppler-glib djvulibre gnome-icon-theme t1lib libsecret desktop-file-utils dconf gsettings-desktop-schemas)
+makedepends=(itstool libnautilus-extension texlive-bin intltool gobject-introspection docbook-xsl python)
+optdepends=('texlive-bin: DVI support'
+ 'gvfs: bookmark support and session saving'
+ 'p7zip: cbz and cb7 compressed comic books'
+ 'tar: cbt compressed comic books'
+ 'libarchive: cbr compressed comic books')
+groups=(gnome)
+install=evince.install
+options=('!emptydirs')
+source=(http://ftp.gnome.org/pub/gnome/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz
+ libarchive.patch)
+sha256sums=('ef22cc29a7cbe70d2e7ce8c0b5b7ee774187ea69f3ae49a64c6d4a91559ef137'
+ '023f01f40c5efb8bf245d97067b3ef1da74f96a0bc53e53eb3d990d6c29b9e5e')
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -Np1 -i ../libarchive.patch
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --libexecdir=/usr/lib/evince \
+ --disable-static --enable-nautilus \
+ --enable-pdf --enable-tiff \
+ --enable-djvu --enable-dvi \
+ --enable-t1lib --enable-comics \
+ --disable-scrollkeeper --disable-schemas-compile \
+ --enable-introspection
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}