summaryrefslogtreecommitdiff
path: root/libre/epiphany/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/epiphany/PKGBUILD')
-rw-r--r--libre/epiphany/PKGBUILD29
1 files changed, 8 insertions, 21 deletions
diff --git a/libre/epiphany/PKGBUILD b/libre/epiphany/PKGBUILD
index a305c0932..a0a044429 100644
--- a/libre/epiphany/PKGBUILD
+++ b/libre/epiphany/PKGBUILD
@@ -10,26 +10,22 @@
# - switched default searchengine to duckduckgo
pkgname=epiphany
-pkgver=3.26.6
+pkgver=3.28.1
pkgrel=1.parabola1
pkgdesc="A GNOME web browser based on the WebKit rendering engine, with DuckDuckGo HTML support"
url="https://wiki.gnome.org/Apps/Web"
arch=(x86_64 i686 armv7h)
license=(GPL)
-depends=(webkit2gtk gcr gnome-desktop icu)
+depends=(webkit2gtk gcr icu)
makedepends=(itstool docbook-xml startup-notification lsb-release
gobject-introspection yelp-tools appstream-glib git meson)
groups=(gnome)
-_commit=0b74e24c3ff3bd7641e90ee97ff44abf949606e5 # tags/3.26.6^0
+_commit=eb7a411968ecb42a49a4cfd108df036d8fdb034e # tags/3.28.1^0
source=("git+https://git.gnome.org/browse/epiphany#commit=$_commit"
- "git+https://git.gnome.org/browse/libgd"
- "git+https://git.gnome.org/browse/gvdb"
pluginsdir.diff
libre.patch)
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- '0e4db79fe22a4ed447aa926eecd09fc660cf2f5aac2d42aa9adaacad45416faf'
+ 'b6c8ee6ace934c053f2fd89758e0b587cb8953c6b0246c1359aecaae4de70289'
'8cee8e5f896ce12832d50e7ab97ef16165d70d135018742e0f5bc15507d4e708')
pkgver() {
@@ -38,26 +34,17 @@ pkgver() {
}
prepare() {
- mkdir build
cd $pkgname
-
patch -Np1 -i ../pluginsdir.diff
patch -Np1 -i ../libre.patch
-
- git submodule init
- git config --local submodule.libgd.url "$srcdir/libgd"
- git config --local submodule.gvdb.url "$srcdir/gvdb"
- git submodule update
-
}
build() {
- cd build
- arch-meson ../$pkgname -Ddistributor_name="Parabola GNU/Linux-libre"
- ninja
+ arch-meson $pkgname build \
+ -D distributor_name="Parabola GNU/Linux-libre"
+ ninja -C build
}
package() {
- cd build
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" ninja -C build install
}