summaryrefslogtreecommitdiff
path: root/libre/dolphin-emu-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/dolphin-emu-libre/PKGBUILD')
-rw-r--r--libre/dolphin-emu-libre/PKGBUILD54
1 files changed, 0 insertions, 54 deletions
diff --git a/libre/dolphin-emu-libre/PKGBUILD b/libre/dolphin-emu-libre/PKGBUILD
deleted file mode 100644
index 44d483aa6..000000000
--- a/libre/dolphin-emu-libre/PKGBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# Maintainer: schuay <jakob.gruber@gmail.com>
-# Contributor: Jeremy Newton (Mystro256)
-# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
-
-_pkgname=dolphin-emu
-pkgname=dolphin-emu-libre
-pkgver=3.5
-pkgrel=4
-epoch=1
-pkgdesc='A Gamecube / Wii / Triforce Emulator, without nonfree nvidia-cg-toolkit'
-arch=('i686' 'x86_64' 'mips64el')
-url='http://dolphin-emu.org'
-license=('GPL2')
-
-makedepends=('cmake' 'glproto' 'opencl-headers')
-depends=('bluez-libs' 'ffmpeg' 'glew' 'libao' 'libgl' 'libxxf86vm' 'lsb-release' 'lzo2' 'mesa' \
- 'openal' 'portaudio' 'sdl' 'wxgtk2.9')
-optdepends=('pulseaudio')
-
-replaces=$_pkgname
-conflicts=$_pkgname
-provides=$_pkgname=$pkgver
-
-source=("http://dolphin-emu.googlecode.com/files/dolphin-${pkgver}-src.zip"
- 'dolphin-emu.desktop'
- 'Dolphin_Logo.png'
- 'gcc48fix.patch')
-
-build() {
- cd "${srcdir}/dolphin-${pkgver}"
-
- # 'u32 __rold' redeclared as different kind of symbol
- # Patch merged upstream, remove with next release (> 3.5)
- patch -lNp1 < "${srcdir}/gcc48fix.patch"
-
- mkdir build && cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-2.9
- make
-}
-
-package() {
- cd "${srcdir}/dolphin-${pkgver}/build"
-
- make DESTDIR=${pkgdir} install
-
- install -Dm644 "${srcdir}/dolphin-emu.desktop" \
- "${pkgdir}/usr/share/applications/dolphin-emu.desktop"
- install -Dm644 "${srcdir}/Dolphin_Logo.png" "${pkgdir}/usr/share/pixmaps/dolphin-emu.png"
-}
-
-md5sums=('4d0429f1e10f0862256e0b4c4e2f44a3'
- 'feed4580c2e6bfbc7f6c67dad861daae'
- 'd15c51f547b4bd47e510faac40bcc9d6'
- 'ddeddc2a65042486565b4b78ad739a80')