summaryrefslogtreecommitdiff
path: root/libre/django1.8/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/django1.8/PKGBUILD')
-rw-r--r--libre/django1.8/PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/libre/django1.8/PKGBUILD b/libre/django1.8/PKGBUILD
index a90272910..ff96740b3 100644
--- a/libre/django1.8/PKGBUILD
+++ b/libre/django1.8/PKGBUILD
@@ -1,10 +1,15 @@
-# $Id$
-# Maintainer: Dan McGee <dan@archlinux.org>
-# Contributor: Shahar Weiss <sweiss4@gmx.net>
+# Maintainer: Luke Shumaker <lukeshu@lukeshu.com>
+# Maintainer (Arch:django): Dan McGee <dan@archlinux.org>
+# Contributor (Arch:django): Shahar Weiss <sweiss4@gmx.net>
+
+# Rational for inclusion in [libre]:
+# - Used by libre/parabolaweb-utils
pkgbase=django
pkgname=('python-django' 'python2-django')
-pkgver=1.8.7
+pkgbase=${pkgbase}1.8
+pkgname=("${pkgname[@]/%/1.8}")
+pkgver=1.8.18
pkgrel=1
pkgdesc="A high-level Python Web framework that encourages rapid development and clean design"
arch=('any')
@@ -12,8 +17,8 @@ license=('BSD')
url="http://www.djangoproject.com/"
makedepends=('python2' 'python2-setuptools' 'python' 'python-setuptools')
source=("https://www.djangoproject.com/m/releases/${pkgver:0:3}/Django-$pkgver.tar.gz")
-md5sums=('44c01355b5efa01938a89b8bd798b1ed')
-sha256sums=('17a66de5cf59b5ee81c3dc57609b145bb45adddc0dc06937b998597d6e7b4523')
+md5sums=('ffc3767f5a06c346fd2d07a18c0ebc54')
+sha256sums=('c7611cdd5e2539a443b7960c7cafd867d986c2720a1b44808deaa60ce3da50c7')
prepare() {
cp -a "$srcdir/Django-$pkgver" "$srcdir/Django-$pkgver-python2"
@@ -30,9 +35,11 @@ build() {
python2 setup.py build
}
-package_python-django() {
+package_python-django1.8() {
depends=('python' 'python-setuptools')
optdepends=('python-psycopg2: for PostgreSQL backend')
+ provides=("python-django=$pkgver")
+ conflicts=('python-django')
cd "$srcdir/Django-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
@@ -48,12 +55,14 @@ package_python-django() {
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-package_python2-django() {
+package_python2-django1.8() {
depends=('python2' 'python2-setuptools')
optdepends=('mysql-python: for MySQL backend'
'python2-psycopg2: for PostgreSQL backend')
replaces=('django')
conflicts=('django')
+ provides=("python2-django=$pkgver")
+ conflicts+=('python2-django')
cd "$srcdir/Django-$pkgver-python2"
python2 setup.py install --root="$pkgdir" --optimize=1