summaryrefslogtreecommitdiff
path: root/libre/db-static/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/db-static/PKGBUILD')
-rw-r--r--libre/db-static/PKGBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/libre/db-static/PKGBUILD b/libre/db-static/PKGBUILD
deleted file mode 100644
index 43ef256cb..000000000
--- a/libre/db-static/PKGBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Maintainer: Márcio Silva <coadde@parabola.nu>
-# based of db
-
-_pkgname=db
-pkgname=db-static
-pkgver=5.3.28
-pkgrel=3
-pkgdesc="The Berkeley DB embedded database system (static libraries only)"
-arch=('i686' 'x86_64' 'armv7h')
-url="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
-license=('custom')
-depends=('db')
-options=('staticlibs')
-source=(http://download.oracle.com/berkeley-db/db-${pkgver}.tar.gz)
-sha1sums=('fa3f8a41ad5101f43d08bc0efb6241c9b6fc1ae9')
-
-build() {
- cd "${srcdir}"/$_pkgname-${pkgver}/build_unix
- ../dist/configure --prefix=/usr --enable-compat185 \
- --disable-shared --enable-static --enable-cxx --enable-dbm \
- --enable-stl
- make LIBSO_LIBS=-lpthread
-}
-
-package() {
- cd "${srcdir}"/$_pkgname-${pkgver}/build_unix
- make DESTDIR="${pkgdir}" install
- rm -r "${pkgdir}"/usr/docs
-
- # remove conflicting files
- rm -vr ${pkgdir}/usr/{bin,include}
-}