summaryrefslogtreecommitdiff
path: root/libre/clementine-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/clementine-libre/PKGBUILD')
-rw-r--r--libre/clementine-libre/PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/libre/clementine-libre/PKGBUILD b/libre/clementine-libre/PKGBUILD
new file mode 100644
index 000000000..defa4ae57
--- /dev/null
+++ b/libre/clementine-libre/PKGBUILD
@@ -0,0 +1,62 @@
+# $Id$
+#Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+#Contributor: BlackEagle <ike.devolder@gmail.com>
+#Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
+#Maintainer (Parabola): Kete <kete@ninthfloor.org>
+#Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
+
+_pkgname=clementine
+pkgname=clementine-libre
+pkgver=1.0.1
+pkgrel=3.1
+pkgdesc="A music player and library organizer, without spotify support"
+url="http://www.clementine-player.org/"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('gstreamer0.10-base' 'taglib' 'glew' 'liblastfm' 'libgpod'
+ 'libmtp' 'libplist' 'hicolor-icon-theme' 'qt' 'libimobiledevice'
+ 'qjson' 'libcdio' 'protobuf' 'qca' 'qca-ossl')
+makedepends=('cmake' 'boost')
+optdepends=('gstreamer0.10-base-plugins: for more open formats'
+ 'gstreamer0.10-good-plugins: for use with "Good" plugin libraries'
+ 'gstreamer0.10-bad-libre-plugins: for use with "Bad" plugin libraries'
+ 'gstreamer0.10-ugly-plugins: for use with "Ugly" plugin libraries')
+replaces=('clementine')
+conflicts=('clementine')
+provides=("clementine=$pkgver")
+source=(http://clementine-player.googlecode.com/files/${_pkgname}-${pkgver}.tar.gz
+ clementine-fix-albumcoverfetch-crash.patch
+ clementine-fresh-start.patch
+ remove-and-disable-spotify.patch
+ remove-nonfree-references-on-translations.patch)
+sha1sums=('e05320da689e2fad744fd3e68518bc4103ecf0fd'
+ 'fddd2e784181ce1dcc7809e7122cbade0af7b01f'
+ 'd8abab4b8fb2d5284a2f43107505325e62d4af5f'
+ '2fef46eaffa7b5cd61afbf19b1dc909d11972a34'
+ '745bc4fd639d7ef3230592c6275fb43b8956f3d5')
+install=clementine.install
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # https://bugs.gentoo.org/401713?id=401713
+ patch -Np1 -i ../clementine-fresh-start.patch
+
+ # http://code.google.com/p/clementine-player/issues/detail?id=2752
+ patch -Np1 -i ../clementine-fix-albumcoverfetch-crash.patch
+
+ # https://labs.parabola.nu/issues/99
+ patch -Np1 -i ../remove-and-disable-spotify.patch
+ patch -Np1 -i ../remove-nonfree-references-on-translations.patch
+
+ # Remove nonfree spotifyblob folder
+ rm -Rf "./spotifyblob"
+
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DENABLE_REMOTE=ON
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}