summaryrefslogtreecommitdiff
path: root/libre/clementine-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/clementine-libre/PKGBUILD')
-rw-r--r--[-rwxr-xr-x]libre/clementine-libre/PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/libre/clementine-libre/PKGBUILD b/libre/clementine-libre/PKGBUILD
index c0a063e95..fb7beb4f6 100755..100644
--- a/libre/clementine-libre/PKGBUILD
+++ b/libre/clementine-libre/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=clementine
pkgname=clementine-libre
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=2
pkgdesc="A music player and library organizer, without spotify support"
url="http://www.clementine-player.org/"
@@ -15,7 +15,7 @@ license=('GPL')
arch=('i686' 'x86_64')
depends=('gstreamer0.10-base' 'taglib' 'glew' 'liblastfm' 'libgpod'
'libmtp' 'libplist' 'hicolor-icon-theme' 'qt' 'libimobiledevice'
- 'qjson' 'libcdio' 'protobuf' 'qca' 'qca-ossl' 'gvfs')
+ 'sparsehash' 'qjson' 'libcdio' 'protobuf' 'qca' 'qca-ossl' 'gvfs')
makedepends=('cmake' 'boost' 'mesa')
optdepends=('gstreamer0.10-base-plugins: for more open formats'
'gstreamer0.10-good-plugins: for use with "Good" plugin libraries'
@@ -26,8 +26,8 @@ conflicts=('clementine')
provides=("clementine=$pkgver")
source=(http://clementine-player.googlecode.com/files/${_pkgname}-${pkgver}.tar.gz
remove-and-disable-spotify.patch)
-sha1sums=('af446aba5ca89edd1541871969b3b6738ffbd05f'
- '3980a00c02e406226f0d08ae9b7e581702c89838')
+sha1sums=('f8d3e9c8f54ac488323ab5a629c9accbe256378e'
+ '4d336b6a42100a268e4d905b9596453f396fb649')
install=clementine.install
build() {
@@ -44,7 +44,9 @@ build() {
rm -v data/icons/svg/spotify.svg
rm -v data/schema/schema-30.sql
rm -v src/{globalsearch/spotifysearchprovider.{cpp,h},internet/spotify{blobdownloader.{cpp,h},server.{cpp,h},service.{cpp,h},settingspage.{cpp,h,ui}}}
-
+
+ # Create a blank file due that is a dependency for clementine
+ touch data/schema/schema-30.sql
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
make