summaryrefslogtreecommitdiff
path: root/libre/calibre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/calibre/PKGBUILD')
-rw-r--r--libre/calibre/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/libre/calibre/PKGBUILD b/libre/calibre/PKGBUILD
index 79b2ccf98..b1d5f819b 100644
--- a/libre/calibre/PKGBUILD
+++ b/libre/calibre/PKGBUILD
@@ -11,7 +11,7 @@
# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
pkgname=calibre
-pkgver=3.13.0
+pkgver=3.15.0
pkgrel=1.parabola1
arch=(x86_64 i686 armv7h)
@@ -27,9 +27,9 @@ depends=(python2-six python2-dateutil python2-cssutils python2-dukpy
python2-netifaces python2-cssselect python2-apsw qt5-webkit
qt5-svg python2-regex python2-pygments mtdev
desktop-file-utils gtk-update-icon-cache optipng udisks2)
-depends_x86_64=(icu=60.1)
-depends_i686=(icu=60.1)
-depends_armv7h=(icu=60.1)
+depends_x86_64=("icu>=60" "icu<61")
+depends_i686=("icu>=60" "icu<61")
+depends_armv7h=("icu>=60" "icu<61")
makedepends=(qt5-x11extras xdg-utils)
optdepends=('ipython2: to use calibre-debug'
'poppler: required for converting pdf to html')
@@ -37,13 +37,13 @@ replaces=($pkgname-libre)
conflicts=($pkgname-libre)
# for updated libre.patch commit id see: https://gitlab.com/libreforks/calibre/tags
-_commit='ce5c919653b60aa8aea611b3ee19dba8'
+_commit='11f261b5db0b2f0d23e5067368ce73d6'
source=("https://download.calibre-ebook.com/$pkgver/calibre-$pkgver.tar.xz"
"https://calibre-ebook.com/signatures/$pkgname-$pkgver.tar.xz.sig"
"https://gitlab.com/libreforks/calibre/uploads/$_commit/libre.patch")
-sha256sums=('84c980e80b61d12797c91bfa0b6ba81926e2fef49ca3082c3e5ea80d161e13a9'
+sha256sums=('8746f52315561d606fd7120fec8284c2e4433f6ead14639c40b4b5f1522273ff'
'SKIP'
- '87b55892d8ba896dd1b29949769001fa5521f85f664b675eb118bba66a42dc5e')
+ 'b218de451ac29081071b6ba965c543bfeb6fb9c5a1bdcedfa02b27811c986dd6')
validpgpkeys=('3CE1780F78DD88DF45194FD706BC317B515ACE7C')
prepare() {