summaryrefslogtreecommitdiff
path: root/libre/calibre-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/calibre-libre/PKGBUILD')
-rw-r--r--libre/calibre-libre/PKGBUILD34
1 files changed, 26 insertions, 8 deletions
diff --git a/libre/calibre-libre/PKGBUILD b/libre/calibre-libre/PKGBUILD
index 57adf177c..8ea1541ec 100644
--- a/libre/calibre-libre/PKGBUILD
+++ b/libre/calibre-libre/PKGBUILD
@@ -1,5 +1,5 @@
-# $Id: PKGBUILD 109846 2014-04-19 07:55:26Z jelle $
-# Maintainer: jelle van der Waa <jelle@vdwaa.nl>
+# $Id: PKGBUILD 110925 2014-05-09 19:15:05Z jelle $
+# Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Petrov Roman <nwhisper@gmail.com>
@@ -9,8 +9,8 @@
_pkgname=calibre
pkgname=calibre-libre
-pkgver=1.33.0
-pkgrel=2
+pkgver=1.36.0
+pkgrel=1
pkgdesc="Ebook management application, without nonfree libunrar support"
arch=('i686' 'x86_64' 'mips64el')
url="http://calibre-ebook.com/"
@@ -27,15 +27,33 @@ replaces=$_pkgname
conflicts=$_pkgname
provides=$_pkgname=$pkgver
install=calibre.install
-source=("http://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz"
+mksource=("http://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz")
+source=("https://repo.parabolagnulinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz"
'desktop_integration.patch'
- 'calibre-mount-helper')
-md5sums=('df51094fe6d5f2e1f10bc070b3d65a68'
+ 'calibre-mount-helper'
+ 'libre.patch')
+mkmd5sums=('713a5a3e526201ca779cc72d93d6eaa5')
+md5sums=('7f6ccc483cb2e1fe57fbd5d471b0805b'
'ece36dfd737fa4a346f0a0e59395e949'
- '675cd87d41342119827ef706055491e7')
+ '675cd87d41342119827ef706055491e7'
+ '64b6798f526165146084e447cc3d9e1a')
+
+mksource(){
+ cd "${srcdir}/${_pkgname}"
+
+ # Remove nonfree unRAR utility files from the source
+ rm -rv src/unrar
+}
prepare(){
cd "${srcdir}/${_pkgname}"
+
+ # Remove nonfree libunrar/cbr support and references
+ rm -v src/calibre/{ebooks/metadata/rar.py,utils/unrar.{cpp,py}}
+ rm -v resources/images/mimetypes/{cbr,rar}.png
+ rm -v imgsrc/mimetypes/rar.svg
+ patch -Np1 -i "${srcdir}/libre.patch"
+
#rm -rf src/{cherrypy,pyPdf}
rm -rf src/cherrypy
rm -rf resources/${pkgname}-portable.*