summaryrefslogtreecommitdiff
path: root/libre/blender-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/blender-libre/PKGBUILD')
-rw-r--r--libre/blender-libre/PKGBUILD78
1 files changed, 19 insertions, 59 deletions
diff --git a/libre/blender-libre/PKGBUILD b/libre/blender-libre/PKGBUILD
index 6fc5679e7..5dd14405d 100644
--- a/libre/blender-libre/PKGBUILD
+++ b/libre/blender-libre/PKGBUILD
@@ -1,22 +1,12 @@
# $Id$
-# Contributor: John Sowiak <john@archlinux.org>
-# Contributor: tobias <tobias@archlinux.org>
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Maintainer (Parabola): Márcio Silva <coadde@adinet.com.uy>
+# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
-# Apparently, the blender guys refuse to release source tarballs for
-# intermediate releases that deal mainly with binaries but incorporate tiny
-# minor changes from svn. Since I'm sick and tired of the urges of users that
-# look for release numbers only, we make a messy PKGBUILD that can checkout svn
-# release if necessary.
-
-_svn=true
_pkgname=blender
pkgname=blender-libre
-true && pkgver=2.63a # Hack for svn
-true && pkgrel=2
+pkgver=2.63a
+pkgrel=2.1
epoch=4
-pkgdesc="A fully integrated 3D graphics creation suite without cuda-toolkit recommendation"
+pkgdesc="A fully integrated 3D graphics creation suite (without nonfree cuda-toolkit support)"
arch=('i686' 'x86_64' 'mips64el')
license=('GPL')
url="http://www.blender.org"
@@ -24,45 +14,19 @@ depends=('libpng' 'libtiff' 'openexr' 'python' 'desktop-file-utils'
'shared-mime-info' 'hicolor-icon-theme' 'xdg-utils' 'glew'
'freetype2' 'openal' 'ffmpeg' 'fftw' 'boost-libs' 'opencollada'
'openimageio' 'libsndfile' 'jack')
-makedepends=('cmake' 'boost' 'subversion')
+makedepends=('cmake' 'boost')
replaces=("${_pkgname}")
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
options=(!strip)
-install=blender.install
-if [[ $_svn = false ]]; then
- source=(http://download.blender.org/source/$_pkgname-$pkgver.tar.gz)
- md5sums=('31a60b3ce5466d965cb7e2648995e092')
-else
- source=(ffmpeg-0.11.patch)
- md5sums=('168db32487e363e71fd4671e204afccf')
-fi
-
-_svntrunk="https://svn.blender.org/svnroot/bf-blender/trunk/blender"
-_svnmod="blender"
+install=${_pkgname}.install
+source=(http://download.${_pkgname}.org/source/${_pkgname}-${pkgver}.tar.gz ffmpeg-0.11.patch)
+md5sums=('31a60b3ce5466d965cb7e2648995e092' '9e5649403e51654615d30b10bc460217')
build() {
-if [[ $_svn = true ]]; then
- cd "$srcdir"
- msg "Connecting to SVN server...."
-
- if [[ -d "$_svnmod/.svn" ]]; then
- (cd "$_svnmod" && svn up )
- else
- svn co "$_svntrunk" --config-dir ./ "$_svnmod"
- fi
-
- msg "SVN checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_svnmod-build"
- cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
- cd "$srcdir/$_svnmod-build"
-else
- cd "$srcdir/$_pkgname-$pkgver"
-fi
+ cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -Np0 < "$srcdir"/ffmpeg-0.11.patch
+ patch -Np1 < "${srcdir}"/ffmpeg-0.11.patch
sed -i "/<libavcodec\/opt.h>/d" intern/ffmpeg/ffmpeg_compat.h
sed -i "/<libavcodec\/opt.h>/d" source/blender/blenkernel/intern/writeffmpeg.c
@@ -96,26 +60,22 @@ fi
make $MAKEFLAGS
-# cp -rf "$srcdir"/${_pkgname}-$pkgver/release/plugins/* \
-# "$srcdir"/${_pkgname}-$pkgver/source/blender/blenpluginapi/
-# cd "$srcdir"/${_pkgname}-$pkgver/source/blender/blenpluginapi
+# cp -rf "${srcdir}/${_pkgname}-${pkgver}"/release/plugins/* \
+# "${srcdir}/${_pkgname}-${pkgver}"/source/blender/blenpluginapi/
+# cd "${srcdir}/${_pkgname}-${pkgver}"/source/blender/blenpluginapi
# chmod 755 bmake
make
}
package() {
- if [[ $_svn = true ]]; then
- cd "$srcdir/$_svnmod-build/build"
- else
- cd "$srcdir/$_pkgname-$pkgver/build"
- fi
+ cd "${srcdir}/${_pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}" install
python -m compileall "${pkgdir}/usr/share/blender"
# install plugins
-# install -d -m755 "$pkgdir"/usr/share/blender/${pkgver%[a-z]}/plugins/{sequence,texture}
-# cp "$srcdir"/${_pkgname}-$pkgver/source/blender/blenpluginapi/sequence/*.so \
-# "$pkgdir"/usr/share/blender/${pkgver%[a-z]}/plugins/sequence/
-# cp "$srcdir"/${_pkgname}-$pkgver/source/blender/blenpluginapi/texture/*.so \
-# "$pkgdir"/usr/share/blender/${pkgver%[a-z]}/plugins/texture/
+# install -d -m755 "${pkgdir}"/usr/share/blender/${pkgver%[a-z]}/plugins/{sequence,texture}
+# cp "${srcdir}/${_pkgname}-${pkgver}"/source/blender/blenpluginapi/sequence/*.so \
+# "${pkgdir}"/usr/share/blender/${pkgver%[a-z]}/plugins/sequence/
+# cp "${srcdir}/${_pkgname}-${pkgver}"/source/blender/blenpluginapi/texture/*.so \
+# "${pkgdir}"/usr/share/blender/${pkgver%[a-z]}/plugins/texture/
}