summaryrefslogtreecommitdiff
path: root/libre/avidemux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/avidemux/PKGBUILD')
-rw-r--r--libre/avidemux/PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/libre/avidemux/PKGBUILD b/libre/avidemux/PKGBUILD
index b5de7c520..93e2b1b46 100644
--- a/libre/avidemux/PKGBUILD
+++ b/libre/avidemux/PKGBUILD
@@ -1,20 +1,30 @@
-# $Id: PKGBUILD 237817 2015-04-21 00:26:23Z foutrelis $
+# $Id: PKGBUILD 243055 2015-08-06 01:32:56Z eric $
# Maintainer (Arch): Eric BĂ©langer <eric@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
pkgbase=avidemux
pkgname=('avidemux-cli' 'avidemux-gtk' 'avidemux-qt')
pkgver=2.5.6
-pkgrel=11.parabola1
-arch=('i686' 'x86_64' 'mips64el')
+pkgrel=12.parabola1
+arch=('i686' 'x86_64')
license=('GPL')
url="http://fixounet.free.fr/avidemux/"
makedepends=('cmake' 'libxslt' 'gtk2' 'qt4' 'jack' 'libvorbis' 'sdl' 'libxv'
- 'alsa-lib' 'lame' 'xvidcore' 'faad2' 'x264-dev' 'libsamplerate'
+ 'alsa-lib' 'lame' 'xvidcore' 'faad2' 'libx264' 'libsamplerate'
'opencore-amr' 'yasm' 'mesa' 'libvpx' 'libpulse' 'libva')
options=('!makeflags' '!emptydirs')
-source=(http://downloads.sourceforge.net/avidemux/avidemux_${pkgver}.tar.gz)
-sha1sums=('47205c236bf6a4435b9d4dd944493c7b7e2752f5')
+source=(http://downloads.sourceforge.net/avidemux/avidemux_${pkgver}.tar.gz
+ mangled-variables-used-attribute.patch)
+sha1sums=('47205c236bf6a4435b9d4dd944493c7b7e2752f5'
+ 'da66b69593da62373f2309f88a284145fbfd99ac')
+
+prepare() {
+ cd ${pkgbase}_${pkgver}
+
+ # Fix build on i686 when using GCC 5.1
+ # https://bugs.archlinux.org/task/45361
+ patch -Np1 -i ../mangled-variables-used-attribute.patch
+}
build() {
cd ${pkgbase}_${pkgver}
@@ -48,7 +58,7 @@ package_avidemux-cli() {
'jack: for the corresponding audio device plugin'
'libpulse: for the corresponding audio device plugin'
'sdl: for the corresponding audio device plugin'
- 'x264: for the corresponding video encoder plugin'
+ 'libx264: for the corresponding video encoder plugin'
'xvidcore: for the corresponding video encoder plugin')
provides=('avidemux')
conflicts=('avidemux' 'avidemux-libre-cli' 'avidemux-cli-parabola')