summaryrefslogtreecommitdiff
path: root/libre/acpi_call/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/acpi_call/PKGBUILD')
-rw-r--r--libre/acpi_call/PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/libre/acpi_call/PKGBUILD b/libre/acpi_call/PKGBUILD
index 8c3766989..ef36595f4 100644
--- a/libre/acpi_call/PKGBUILD
+++ b/libre/acpi_call/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer (Arch): Maxime Gauduin <alucryd@archlinux.org>
-# Contributor (Arch): mortzu <me@mortzu.de>
-# Contributor (Arch): fnord0 <fnord0@riseup.net>
-# Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
-# Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
+# Maintainer (arch): Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: mortzu <me@mortzu.de>
+# Contributor: fnord0 <fnord0@riseup.net>
+# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_basekernel=5.15.12
+_basekernel=5.17.3
pkgname=acpi_call
pkgver=1.2.2
-pkgrel=11
+pkgrel=40
pkgrel+=.parabola1.basekernel${_basekernel}
pkgdesc='A linux kernel module that enables calls to ACPI methods through /proc/acpi/call'
pkgdesc+=' (for linux-libre)'
url='https://github.com/mkottman/acpi_call'
arch=('x86_64')
-arch+=('i686' 'armv7h')
+arch+=('armv7h' 'i686')
license=('GPL')
-makedepends=("linux-libre-headers=${_basekernel}" "acpi_call-dkms=$pkgver")
+makedepends=(linux-libre-headers=${_basekernel} "acpi_call-dkms=$pkgver")
+makedepends+=(gcc=11.2.0) # `dkms` requires the same compiler version which built the kernel
conflicts=('acpi_call-dkms')
build() {