summaryrefslogtreecommitdiff
path: root/libre/abuse/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/abuse/PKGBUILD')
-rw-r--r--libre/abuse/PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/libre/abuse/PKGBUILD b/libre/abuse/PKGBUILD
index 2c378030d..397151480 100644
--- a/libre/abuse/PKGBUILD
+++ b/libre/abuse/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=abuse
_pkgname=$pkgname-libre
pkgver=0.8
-pkgrel=6.parabola1
+pkgrel=6.parabola2
pkgdesc='Side-scroller action game that pits you against ruthless alien killers, without nonfree claudio support'
arch=('x86_64' 'i686' 'armv7h')
url='http://abuse.zoy.org/'
@@ -18,30 +18,31 @@ replaces=($_pkgname)
conflicts=($_pkgname)
depends=('gcc-libs' 'libgl' 'sdl_mixer' 'glu' 'desktop-file-utils')
makedepends=('gendesk' 'mesa-libgl' 'glu')
-mksource=("http://$pkgname.zoy.org/raw-attachment/wiki/download/$pkgname-$pkgver.tar.gz"
- 'non-claudio.patch')
+mksource=("http://$pkgname.zoy.org/raw-attachment/wiki/download/$pkgname-$pkgver.tar.gz")
source=("https://repo.parabola.nu/other/$_pkgname/$_pkgname-$pkgver.tar.gz"
"$pkgname.sh"
"default.${pkgname}rc"
- 'default.gamma.lsp')
-mksha256sums=('0104db5fd2695c9518583783f7aaa7e5c0355e27c5a803840a05aef97f9d3488'
- '017cb58acf5ba8cdb889f97a758318cb66ab4947b860a77ab16b932c3f21b98f')
-sha256sums=('ff7018b3ddcc6d2e702bc14eb2884622677ac5141c36e1fc0cdd127df3017f7d'
+ 'default.gamma.lsp'
+ 'libre.patch')
+mksha256sums=('0104db5fd2695c9518583783f7aaa7e5c0355e27c5a803840a05aef97f9d3488')
+sha256sums=('8f77e8020bf17b10d8a5269d7d4d9bc3592f961ce352672ce183e1f41efc956b'
'a5ddac71ca9b8c4bb42bdf91393a5fbe3d839ab9a9e9a6362a75dafc2aab122e'
'6ea2fa9e65c10bbcab4432f40d0c7284cb3970835c40c5c00ced14b39ce1b00f'
- '13df83fea60918d29d5141cdfbd8d56147c053e88d3701209ae676f46447c2f6')
+ '13df83fea60918d29d5141cdfbd8d56147c053e88d3701209ae676f46447c2f6'
+ '7566a3affb01c64ff4f859bcd549661220847e9c62327e71e1d585c0048f90ea')
mksource() {
cd "$pkgname-$pkgver"
# Remove the nonfree claudio addon
rm -rvf ./data/addon/claudio
- patch -Np1 -i "$srcdir/non-claudio.patch"
}
prepare() {
cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/libre.patch"
+
gendesk -n -f --pkgname "$pkgname" --pkgdesc "$pkgdesc"
}