summaryrefslogtreecommitdiff
path: root/libre/abiword/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/abiword/PKGBUILD')
-rw-r--r--libre/abiword/PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/libre/abiword/PKGBUILD b/libre/abiword/PKGBUILD
index 86623786b..8793aead9 100644
--- a/libre/abiword/PKGBUILD
+++ b/libre/abiword/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=abiword
pkgver=3.0.1
-pkgrel=4.parabola1
+pkgrel=5.parabola1
arch=('i686' 'x86_64')
pkgdesc='Fully-featured word processor, without Google search engine and nonfree fonts support'
license=('GPL')
@@ -25,6 +25,7 @@ source=(http://abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.
abiword-3.0.0-link-grammar-5-second.patch
link-grammar-panic.patch
aiksaurus-plugin.m4
+ command-plugin.m4
gnutls-3.4.0.patch
liberation-fonts.patch)
sha256sums=('e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6'
@@ -33,6 +34,7 @@ sha256sums=('e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6'
'd2c80da81a339634a7a4ee4cef12f7ee968f2c2a8c2f75533b6713b71f0d61fd'
'94d1e638f7b85123dc2282d2e59b982bde6ad0dbbe1b6b54351e610c5a0ea578'
'5f80a2f94f9929cdba9809c5e1a87cd5d537a2518bb879bfb9eab51a71c8dac1'
+ '2f26826e9d59d80dacd0dae4aceb815804eaa75954e47507a0897794f33e45be'
'b393e26c19f92901f64d2bae54c86708ea7dd0b647572088a8ac0cd2eec89100'
'8a0b6e444e937924743f95c747cbe395a30fb8677a010e60c973b9039e258079')
@@ -49,11 +51,15 @@ prepare() {
# Fix build with new gnutls 3.4.x
patch -Np0 -i ../gnutls-3.4.0.patch
+ # python2 fix
+ sed -i 's/python -c/python2 -c/' src/gi-overrides/Makefile.{am,in}
+
# Replace nonfree fonts support to liberation fonts
patch -Np1 -i ../liberation-fonts.patch
# Install missing m4 file
install -m644 ../aiksaurus-plugin.m4 plugins/aiksaurus/plugin.m4
+ install -m644 ../command-plugin.m4 plugins/command/plugin.m4
# Generate m4 file for configure
find plugins -name plugin.m4 | xargs cat > plugin-configure.m4
@@ -77,6 +83,7 @@ build() {
passepartout pdb pdf presentation psion s5 sdw t602 urldict \
wikipedia wmf wml wordperfect wpg xslfo" \
--enable-introspection
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}