summaryrefslogtreecommitdiff
path: root/libre/abiword/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/abiword/PKGBUILD')
-rw-r--r--libre/abiword/PKGBUILD36
1 files changed, 10 insertions, 26 deletions
diff --git a/libre/abiword/PKGBUILD b/libre/abiword/PKGBUILD
index 1f30fcd37..b92e4d879 100644
--- a/libre/abiword/PKGBUILD
+++ b/libre/abiword/PKGBUILD
@@ -6,9 +6,9 @@
# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=abiword
-pkgver=3.0.2
-pkgrel=9
-pkgrel+=.par1
+pkgver=3.0.4
+pkgrel=1
+pkgrel+=.parabola1
pkgdesc='Fully-featured word processor'
pkgdesc+=', without Google search engine and nonfree fonts support'
arch=('x86_64')
@@ -18,32 +18,28 @@ url='https://www.abisource.com'
depends=('fribidi' 'wv' 'goffice' 'librsvg' 'enchant' 'desktop-file-utils'
'redland' 'libical' 'gtk-update-icon-cache' 'loudmouth' 'libwpg' 'libwps' 'libwmf' 'link-grammar'
'gtkmathview' 'aiksaurus' 'libxslt' 'libsoup' 'libots' 'libgsf' 'psiconv')
-makedepends=('pkgconfig' 'asio' 'boost' 'gobject-introspection' 'libwpd' 'libwps' 'python2-gobject' 'python-gobject')
+makedepends=('pkgconfig' 'asio' 'boost' 'gobject-introspection' 'libwpd' 'libwps' 'python2-gobject' 'python-gobject' 'autoconf-archive')
conflicts=('abiword-plugins' 'abiword-libre')
replaces=('abiword-plugins' 'abiword-libre')
options=(!makeflags)
-source=(https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+source=(https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz{,.asc}
abiword-3.0.0-librevenge.patch
abiword-3.0.1-libwps-0.4.patch
aiksaurus-plugin.m4
command-plugin.m4
python-override.patch
- bug13815.patch
enchant-2.1.patch
- libical-deprecated.patch
- liberation-fonts.patch
- fix-flickering.patch)
-sha256sums=('afbfd458fd02989d8b0c6362ba8a4c14686d89666f54cfdb5501bd2090cf3522'
+ liberation-fonts.patch)
+sha256sums=('e93096cb192e5bc19d62e180fc5eda643206465315a710113ae5036bc2a1a5d7'
+ 'SKIP'
'77b52a3722096cec3bfbe4fff3802f51b6c9e0ff7aaa30028c29825fd4e6a65f'
'f1375b2ab7af2959717cba0259ba546c8e75ef849e84263bdc253019e849cb2a'
'5f80a2f94f9929cdba9809c5e1a87cd5d537a2518bb879bfb9eab51a71c8dac1'
'2f26826e9d59d80dacd0dae4aceb815804eaa75954e47507a0897794f33e45be'
'dba1e3265cd42589f17b41fea1a39c8aa4b83c7203b9d5944b578d0ff9c858be'
- '05f2544a177d6f58424af9045c26e82aca64938d0daf00f43f6b99a2abf64496'
'444dc2aadea3c80310a509b690097541573f6d2652c573d04da66a0f385fcfb2'
- 'fe6eec4129777117bbfd5fa12d02208e430c8a3b96a54dcf8574ce800f240489'
- '8a0b6e444e937924743f95c747cbe395a30fb8677a010e60c973b9039e258079'
- '4497da364256340ccd9a60c2fc858a6999f1b2ebc2dad5e6d297e7ab9cabccef')
+ '8a0b6e444e937924743f95c747cbe395a30fb8677a010e60c973b9039e258079')
+validpgpkeys=('6C44DB3E0BF3EAF5B433239A5FEE05E6A56E15A3') # Hubert Figuiere <hub@figuiere.net>
prepare() {
cd $pkgname-$pkgver
@@ -57,24 +53,12 @@ prepare() {
# Fix python override code to work with Python 3.x
patch -Np1 -i ../python-override.patch
- # Fix black on black (FS#51667)
- # http://bugzilla.abisource.com/show_bug.cgi?id=13815
- patch -Np1 -i ../bug13815.patch
-
# Replace deprecated enchant functions
patch -Np1 -i ../enchant-2.1.patch
- # Replace deprecated libical functions
- patch -Np1 -i ../libical-deprecated.patch
-
# Replace nonfree fonts support to liberation fonts
patch -Np1 -i ../liberation-fonts.patch
- # Fix incessant flickering
- # https://bugzilla.abisource.com/show_bug.cgi?id=13791
- # https://sources.debian.org/patches/abiword/3.0.2-6/
- patch -Np1 -i ../fix-flickering.patch
-
# Install missing m4 file
install -m644 ../aiksaurus-plugin.m4 plugins/aiksaurus/plugin.m4
install -m644 ../command-plugin.m4 plugins/command/plugin.m4