summaryrefslogtreecommitdiff
path: root/libre-testing/syslinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/syslinux/PKGBUILD')
-rw-r--r--libre-testing/syslinux/PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/libre-testing/syslinux/PKGBUILD b/libre-testing/syslinux/PKGBUILD
new file mode 100644
index 000000000..f9907d3f4
--- /dev/null
+++ b/libre-testing/syslinux/PKGBUILD
@@ -0,0 +1,63 @@
+# $Id: PKGBUILD 187808 2013-06-06 07:51:31Z tpowa $
+# Maintainer: Thomas Bächler <thomas@archlinux.org>
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
+
+pkgname=syslinux
+pkgver=5.10
+pkgrel=3
+arch=('i686' 'x86_64')
+pkgdesc="Collection of boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE (Parabola rebranded)"
+url="http://www.syslinux.org"
+license=('GPL2')
+depends=('perl' 'glibc')
+optdepends=('perl-passwd-md5: For md5pass'
+ 'perl-digest-sha1: For sha1pass'
+ 'mtools: For mkdiskimage and syslinux support'
+ 'gptfdisk: For GPT support'
+ 'util-linux: For isohybrid')
+makedepends=('nasm')
+backup=('boot/syslinux/syslinux.cfg'
+ 'boot/syslinux/splash.png')
+install=syslinux.install
+source=(http://www.kernel.org/pub/linux/utils/boot/syslinux/$pkgname-${pkgver}.tar.bz2
+ syslinux-dont-build-dos-windows-targets.patch
+ syslinux.cfg
+ syslinux-install_update
+ splash.png)
+md5sums=('8f51d6a5d2730f534ba90e71f3347bff'
+ '25af85a05e7b212b7fb8b7587175e492'
+ 'e5a69630e3f7083aad2d14362b6117b3'
+ '4450792e13a0270c1b89bb6a66ce2fbc'
+ 'befd0e7c38a03442b791f2a530b4dd2d')
+
+build() {
+ # Do not try to build syslinux with our default LDFLAGS, it will fail
+ unset LDFLAGS
+ cd "$srcdir"/$pkgname-${pkgver}
+ # Do not try to build the Windows or DOS installers
+ patch -p1 -i "$srcdir"/syslinux-dont-build-dos-windows-targets.patch
+ # Fix FHS manpage path
+ sed 's|/usr/man|/usr/share/man|g' -i mk/syslinux.mk
+ make installer
+ make -C utils
+ make -C com32
+}
+
+package() {
+ cd "$srcdir"/$pkgname-${pkgver}
+ make INSTALLROOT="$pkgdir" AUXDIR=/usr/lib/syslinux install
+
+ # install docs
+ cp -ar "$srcdir"/$pkgname-${pkgver}/doc "$pkgdir"/usr/share/
+ # Install the default configuration
+ install -D -m644 "$srcdir"/syslinux.cfg "$pkgdir"/boot/syslinux/syslinux.cfg
+ # Install Parabola splash
+ install -D -m644 "$srcdir"/splash.png "$pkgdir"/boot/syslinux/splash.png
+ # Install the installation and update script
+ # This script is maintained at git://gist.github.com/772138.git
+ install -D -m755 "$srcdir"/syslinux-install_update "$pkgdir"/usr/bin/syslinux-install_update
+ # move extlinux binary to /usr/bin
+ mv "$pkgdir"/sbin/extlinux "$pkgdir"/usr/bin/extlinux
+ rmdir "$pkgdir"/sbin
+}