summaryrefslogtreecommitdiff
path: root/libre-testing/qt5-webengine/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/qt5-webengine/PKGBUILD')
-rw-r--r--libre-testing/qt5-webengine/PKGBUILD59
1 files changed, 0 insertions, 59 deletions
diff --git a/libre-testing/qt5-webengine/PKGBUILD b/libre-testing/qt5-webengine/PKGBUILD
deleted file mode 100644
index 7d485dd24..000000000
--- a/libre-testing/qt5-webengine/PKGBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# $Id: PKGBUILD 240297 2015-06-03 10:22:03Z fyan $
-# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
-# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-# Contributor: Luke R. <g4jc@openmailbox.org>
-
-pkgname=qt5-webengine
-_qtver=5.8.0
-pkgver=${_qtver/-/}
-pkgrel=1.parabola1
-arch=('i686' 'x86_64')
-url='http://qt-project.org/'
-license=('LGPL3' 'LGPL2.1' 'BSD')
-pkgdesc='Provides support for web applications using the Chromium browser project, without nonfree codecs'
-depends=('qt5-webchannel' 'qt5-location' 'libxcomposite' 'libxrandr' 'pciutils' 'libxss' 'libvpx'
- 'libevent' 'libsrtp' 'snappy' 'nss' 'protobuf' 'libxslt' 'minizip' 'ffmpeg')
-makedepends=('python2' 'git' 'gperf' 'jsoncpp')
-groups=('qt' 'qt5')
-_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
-source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz" qt5-webengine-nss.patch
- qtwebengine-5.7.0-icu58.patch)
-
-md5sums=('6e7fb2be161c6db4d988a4f5b329672f'
- '2a1610b34204102938a24154a52e5571'
- '9d225d1bf83ea45dbf6556d30d35fcb8')
-
-prepare() {
- mkdir -p build
-
- # Hack to force using python2
- mkdir -p bin
- ln -s /usr/bin/python2 bin/python
-
- # Fix opening some websites with recent NSS https://github.com/QupZilla/qupzilla/issues/1870 (KaOSx patch)
- cd ${_pkgfqn}
- # patch -p1 -i ../qt5-webengine-nss.patch
-
- # Fix build with ICU 58 (gentoo)
- patch -p1 -i "$srcdir"/qtwebengine-5.7.0-icu58.patch
-}
-
-build() {
- cd build
-
- export PATH="$srcdir/bin:$PATH"
- qmake WEBENGINE_CONFIG+="use_system_ffmpeg use_system_icu" ../${_pkgfqn}
- make
-}
-
-package() {
- cd build
- make INSTALL_ROOT="$pkgdir" install
-
- # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
- find "$pkgdir/usr/lib" -type f -name '*.prl' \
- -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
-
- install -Dm644 "$srcdir"/${_pkgfqn}/src/3rdparty/chromium/LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE.chromium
-}