summaryrefslogtreecommitdiff
path: root/libre-testing/icedove/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/icedove/PKGBUILD')
-rw-r--r--libre-testing/icedove/PKGBUILD235
1 files changed, 235 insertions, 0 deletions
diff --git a/libre-testing/icedove/PKGBUILD b/libre-testing/icedove/PKGBUILD
new file mode 100644
index 000000000..f3b15e8d2
--- /dev/null
+++ b/libre-testing/icedove/PKGBUILD
@@ -0,0 +1,235 @@
+# Maintainer (arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Dale Blount <dale@archlinux.org>
+# Contributor: Anders Bostrom <anders.bostrom@home.se>
+# Maintainer: Andreas Grapentin <andreas@grapentin.org>
+# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
+# Contributor: Luke R. <g4jc@openmailbox.org>
+# Contributor: Isaac David <isacdaavid@isacdaavid.info>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
+
+# parabola changes and rationale:
+# - rebranded to icedove
+# - added makedepends for branding: quilt mozilla-searchplugins imagemagick
+# - disabled tests, they break in an environment without network access.
+# - disabled geo-location
+
+
+_pkgname=thunderbird
+pkgname=icedove
+epoch=1
+pkgver=78.9.1
+pkgrel=1
+pkgrel+=.parabola1
+_brandingver=78.9
+_brandingrel=1
+pkgdesc='Standalone mail and news reader based on Mozilla Thunderbird'
+url=https://wiki.parabola.nu/${pkgname}
+arch=(x86_64)
+arch+=(i686 armv7h)
+license=(MPL GPL LGPL)
+depends=(
+ glibc gtk3 libgdk-3.so mime-types dbus libdbus-1.so dbus-glib alsa-lib nss
+ hunspell sqlite ttf-font libvpx libvpx.so zlib bzip2 botan libwebp libevent
+ libjpeg-turbo libffi nspr gcc-libs libx11 libxrender libxfixes libxext
+ libxcomposite libxdamage pango libpango-1.0.so cairo gdk-pixbuf2 icu
+ libicui18n.so libicuuc.so freetype2 libfreetype.so fontconfig
+ libfontconfig.so glib2 libglib-2.0.so pixman libpixman-1.so gnupg
+)
+optdepends=(
+ 'libotr: OTR support for active one-to-one chats'
+)
+makedepends=(
+ unzip zip diffutils python python-setuptools yasm nasm mesa imake libpulse
+ inetutils xorg-server-xvfb autoconf2.13 rust clang llvm gtk2 cbindgen nodejs
+ gawk perl findutils libotr
+)
+#makedepends[15]='llvm10' # FIXME: DEBUG: | rustup: error while loading shared libraries: libLLVM-10.so: cannot open shared object file: No such file or directory
+# # ERROR: Command `rustup which rustc` failed with exit status 127.
+makedepends+=(quilt imagemagick)
+replaces=(${_pkgname})
+options=(!emptydirs !makeflags)
+source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz{,.asc}
+ $pkgname.desktop
+ vendor-prefs.js
+ distribution.ini
+ mozconfig.cfg
+ configure-fix-passing-system-bzip2-ldflags.patch
+ thunderbird-78.5-rust-1.48.patch)
+source+=(https://repo.parabola.nu/other/icedove/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz{,.sig})
+source_armv7h=(arm-wasm-vfp.patch)
+sha512sums=('fa27a327ce10a0c16877ac02338aace257f60f69af40d12ae5bb2055f6536db9ba45995765ac0eaa1aea2fa2b353ac9dc6eb06fcdf6cb4ae6fafcd65fe5970c6'
+ 'SKIP'
+ 'a3c9815491d9bed0440c60f35867a5b8a2a1343521f288035fcc46e651a11b926c75a9eca2d262b43d510a7a7119709b53637f1b00ddbbee8e5b0a4b33d7b8fd'
+ 'e21d30a8b79724eda3488ac2bf9dfeb0c7f6bf39e59c37f17574b529d33043765eb54408a55fcbf6f3afa7a58ca99124992d443cdff23ac5c9bdbff33c75f60f'
+ '31d46f91d9612d30d8553a19d0d309d743467e58b568a4aeea3caf6bd805ba00656561c84a1511c59bce1cf24ba323bfad2cd26a19985f1bf7dfb6d282642972'
+ '1eba1593ff0a9642d89e6d3e03388b1aef00437b2f6c1f0d81d250d9845b80e057c246eaeb31d8d22001abd65556a9603d1db597baf864481a5bfb7000886b29'
+ 'e3ed2708b8354015cb3d2c81048d1ce4932d1effbe2b40efa7cf9b45c1b923b9fd708645e2f8aa0136a485a3f7ce6b396b85721aaf535a4a764fd5005fb7e222'
+ 'bbb8b0e7b9c67372eb22e1d6b6b5758fe504ded84c40a076d4a064374a1bf34ac12d5b514b328ac9ca984d976b9e0fbde81e68a66bec915c997d6be0c0917584')
+sha512sums_armv7h=('c25883c4860e511a99d9fbfba5b824145c0862729101721605725f609ca2a41848b741dd100eff390f57031dc5f14af3ea30133de30f75cb20197c420ae20972')
+sha512sums+=('78fee952c9bc826a0a7ec262d442150177bf887349641279dafae803b9832a0dd9b8d0722cc084459077a5310eb4f6de6a8d7ffaff6741afe1359f292a373f34'
+ 'SKIP')
+validpgpkeys=(14F26682D0916CDD81E37B6D61B7B526D98F0353) # Mozilla Software Releases <release@mozilla.com>
+validpgpkeys+=(BFA8008A8265677063B11BF47171986E4B745536 # Andreas Grapentin
+ 3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40) # bill-auger
+
+
+prepare() {
+ cd $_pkgname-$pkgver
+
+ echo "${noextract[@]}"
+
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ [[ $src = arm-wasm-vfp.patch ]] && continue # defer parabola patches
+
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
+
+ cp ../mozconfig.cfg .mozconfig
+ sed "s|@PWD@|${PWD@Q}|g" -i .mozconfig
+
+ case "${CARCH}" in
+ armv*)
+ patch -Np1 -i "${srcdir}"/arm-wasm-vfp.patch
+
+ sed -i '/--enable-linker=gold/d' .mozconfig
+ sed -i '/--enable-hardening/d' .mozconfig
+ sed -i '/--enable-optimize/d' .mozconfig
+
+ export MOZ_DEBUG_FLAGS=" "
+ export CFLAGS+=" -g0"
+ export CXXFLAGS+=" -g0"
+ export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ export RUSTFLAGS="-Cdebuginfo=0"
+
+ cat >> .mozconfig <<END
+ac_add_options --disable-webrtc
+ac_add_options --disable-elf-hack
+ac_add_options --enable-optimize="-g0 -O2"
+END
+ ;;
+ i686)
+ sed -i 's/--enable-linker=gold/--enable-linker=bfd/' .mozconfig
+ LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ export LDFLAGS
+ ;;
+ esac
+
+ # perform re-branding
+ local branding_indir="${srcdir}"/${pkgname}-${_brandingver}
+ local branding_outdir=comm/mail/branding/${pkgname}
+ rm -rf -- ${branding_outdir}
+ cp -aT -- "${branding_indir}"/${pkgname}-branding ${branding_outdir}
+
+ export QUILT_PATCHES="${branding_indir}"/patches
+ export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
+ export QUILT_DIFF_ARGS='--no-timestamps'
+ quilt push -av
+
+ # generate icons
+ for i in 16 22 24 32; do
+ rsvg-convert -w ${i} -h ${i} "${branding_indir}"/app-icons/${pkgname}_small.svg \
+ -o "${branding_outdir}/default${i}.png"
+ done
+ for i in 48 64 128 256; do
+ rsvg-convert -w ${i} -h ${i} "${branding_indir}"/app-icons/${pkgname}_big.svg \
+ -o "${branding_outdir}/default${i}.png"
+ done
+ cp "${branding_indir}"/logo/icedove_icon.svg ${branding_outdir}/
+ cp -av "${branding_indir}"/preview.png comm/mail/themes/linux/mail/preview.png
+
+ # Patch search-engines config
+ local search_engines_sed_cmd='s|https://duckduckgo.com/|https://html.duckduckgo.com/html/|'
+ local engines_cfg_dir=comm/mail/components/search/extensions
+ sed -i "${search_engines_sed_cmd}" ${engines_cfg_dir}/ddg/manifest.json
+
+ # Delete unused search engine configs
+ find ${engines_cfg_dir} -mindepth 1 -maxdepth 1 \
+ -not -name ddg \
+ -not -name wikipedia \
+ -exec rm -rf {} \;
+
+ # Patch and remove anything that's left
+ sed -i '\|Phishing Protection|d
+ \|UrlClassifier|d
+ \|URLClassifier|d
+ \|url-classifier|d
+ ' comm/mail/installer/package-manifest.in
+ # TODO: this could be moved into the branding package - it already processes all-thunderbird.js
+ sed -i '\|extensions[.]getAddons[.]get[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://directory.fsf.org/wiki/Icedove");|g;
+ \|extensions[.]getAddons[.]search[.]browseURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|https://directory.fsf.org/wiki/Icedove");|g;
+ \|extensions[.]getAddons[.]search[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://directory.fsf.org/wiki/Icedove");|g;
+ \|extensions[.]webservice[.]discoverURL| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://directory.fsf.org/wiki/Icedove");|g;
+ ' comm/mail/app/profile/all-thunderbird.js
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ if [[ -n "${SOURCE_DATE_EPOCH}" ]]; then
+ export MOZ_BUILD_DATE=$(date --date "@${SOURCE_DATE_EPOCH}" "+%Y%m%d%H%M%S")
+ fi
+
+ # clang-{9,10,11} -> error: unknown argument: '-fvar-tracking-assignments'
+ CFLAGS="${CFLAGS/-fvar-tracking-assignments/}"
+ CXXFLAGS="${CXXFLAGS/-fvar-tracking-assignments/}"
+
+ case "${CARCH}" in
+ armv*)
+ export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ sed -i "s/\(cargo_rustc_flags += -C lto\)/#\1/" config/rules.mk
+ sed -i "s/debug_info = '2'/debug_info = '1'/" build/moz.configure/toolchain.configure
+ export MOZ_MAKE_FLAGS=-j1
+ ;;
+ i686)
+ sed -i "s/\(cargo_rustc_flags += -C lto\)/#\1/" config/rules.mk
+ sed -i "s/debug_info = '2'/debug_info = '1'/" build/moz.configure/toolchain.configure
+ export MOZ_MAKE_FLAGS=-j1
+ ;;
+ esac
+
+ ./mach configure
+ ./mach build
+ ./mach buildsymbols
+}
+
+package() {
+ optdepends=('libcanberra: sound support')
+
+ cd $_pkgname-$pkgver
+ DESTDIR="$pkgdir" ./mach install
+
+ install -Dm 644 ../vendor-prefs.js -t "$pkgdir/usr/lib/$pkgname/defaults/pref"
+ install -Dm 644 ../distribution.ini -t "$pkgdir/usr/lib/$pkgname/distribution"
+ install -Dm 644 ../$pkgname.desktop -t "$pkgdir/usr/share/applications"
+
+ for i in 16 22 24 32 48 64 128 256; do
+ install -Dm644 comm/mail/branding/$pkgname/default${i}.png \
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
+ done
+ install -Dm644 comm/mail/branding/$pkgname/${pkgname}_icon.svg \
+ "$pkgdir/usr/share/icons/hicolor/symbolic/apps/$pkgname-symbolic.svg"
+
+ # Use system-provided dictionaries
+ ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
+ ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
+
+ # Install a wrapper to avoid confusion about binary path
+ install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
+#!/bin/sh
+exec /usr/lib/$pkgname/$pkgname "\$@"
+END
+
+ # Replace duplicate binary with wrapper
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ ln -srf "$pkgdir/usr/bin/$pkgname" \
+ "$pkgdir/usr/lib/$pkgname/$pkgname-bin"
+}