summaryrefslogtreecommitdiff
path: root/libre-multilib/pcsx2-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-multilib/pcsx2-libre/PKGBUILD')
-rw-r--r--libre-multilib/pcsx2-libre/PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/libre-multilib/pcsx2-libre/PKGBUILD b/libre-multilib/pcsx2-libre/PKGBUILD
index 9331100aa..1be2e2cb6 100644
--- a/libre-multilib/pcsx2-libre/PKGBUILD
+++ b/libre-multilib/pcsx2-libre/PKGBUILD
@@ -1,17 +1,17 @@
-# $Id: PKGBUILD 103474 2014-01-06 14:09:29Z alucryd $
+# $Id: PKGBUILD 105845 2014-02-16 10:30:11Z alucryd $
# Maintainer: Maxime Gauduin <alucryd@gmail.com>
# Contributor: josephgbr <rafael.f.f1@gmail.com>
# Contributor: vEX <vex@niechift.com>
_pkgname=pcsx2
pkgname=$_pkgname-libre
-pkgver=1.1.0.r5797
+pkgver=1.2.2
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator, without nonfree nvidia-cg-toolkit support'
arch=('i686' 'x86_64')
url='http://www.pcsx2.net'
-license=('GPL')
-makedepends=('cmake' 'sparsehash' 'svn')
+license=('GPL2' 'GPL3' 'LGPL2.1' 'LGPL3')
+makedepends=('cmake' 'sparsehash')
if [[ $CARCH == "i686" ]]; then
depends=('glew' 'libaio' 'libcanberra' 'libjpeg-turbo' 'portaudio' 'sdl2' 'soundtouch' 'wxgtk2.8')
elif [[ $CARCH == "x86_64" ]]; then
@@ -21,11 +21,17 @@ provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
replaces=("$_pkgname")
options=('!emptydirs')
-source=("${_pkgname}::svn+http://pcsx2.googlecode.com/svn/trunk/#revision=${pkgver#*r}")
-sha256sums=('SKIP')
+source=("https://github.com/PCSX2/pcsx2/archive/v${pkgver}.tar.gz")
+sha256sums=('4fccef58098d099ffe955fadd5ceee78ed063ab585b8772f4242fd6dc5fd2d23')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ # remove Cg shader on ZZogl plugin
+ sed -i '\|zzogl-pg-cg| s|^|#|' plugins/CMakeLists.txt
+}
build() {
- cd ${_pkgname}
+ cd ${_pkgname}-${pkgver}
if [[ -d build ]]; then
rm -rf build
@@ -45,7 +51,7 @@ build() {
}
package() {
- cd ${_pkgname}/build
+ cd ${_pkgname}-${pkgver}/build
if [[ $CARCH == "x86_64" ]]; then
depends=('lib32-glew' 'lib32-libaio' 'lib32-libcanberra' 'lib32-libjpeg-turbo' 'lib32-portaudio' 'lib32-sdl2' 'lib32-soundtouch' 'lib32-wxgtk2.8')