summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-pae/PKGBUILD')
-rw-r--r--kernels/linux-libre-pae/PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/kernels/linux-libre-pae/PKGBUILD b/kernels/linux-libre-pae/PKGBUILD
index dfa7e5ed7..2234a4d16 100644
--- a/kernels/linux-libre-pae/PKGBUILD
+++ b/kernels/linux-libre-pae/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 218478 2014-08-01 07:04:17Z tpowa $
+# $Id: PKGBUILD 219731 2014-08-14 06:02:01Z tpowa $
# Contributor (Arch): Tobias Powalowski <tpowa@archlinux.org>
# Contributor (Arch): Thomas Baechler <thomas@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
@@ -10,8 +10,8 @@
pkgbase=linux-libre-pae # Build stock -libre-pae kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.15
-pkgver=${_basekernel}.8
+_basekernel=3.16
+pkgver=${_basekernel}.1
pkgrel=1
arch=('i686')
url="http://linux-libre.fsfla.org/"
@@ -25,13 +25,15 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
'boot-logo.patch'
- 'change-default-console-loglevel.patch')
-sha256sums=('93450dc189131b6a4de862f35c5087a58cc7bae1c24caa535d2357cc3301b688'
- '6dfa7e972f54feef3a40047704495c00b4e163d7f164c133aaaa70871ab61afe'
- 'c99a01117feaa7e6ef21c1ef538573ea3e873f58f68f7bd33f33a62fd4202fe7'
+ 'change-default-console-loglevel.patch'
+ 'compal-laptop-hwmon-fix.patch')
+sha256sums=('9c2a524c901febe0f0138f702bfdeb52d6f79f22c1fdbabaa37580bc70f16218'
+ '3bbc78694d76b12b6229799d7c4daf5215b9dd731908d96b03603aceb54ad5c7'
+ 'd7f16bb97225fc315cbe0bdf5fbc30ee8e387298bd53ba7cc623044b2f48c506'
'292d5c553f87246c8dc2d57cadfd2db92a3750173b4588d53c2919743171eca5'
'8303b426b1a6dce456b2350003558ae312d21cab0ae6c1f0d7b9d21395f4e177'
- 'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182')
+ '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
+ 'f36f61a0a72bcb0a9c04264343503bfbf927c9ea0db819e66734a3933b060588')
_kernelname=${pkgbase#linux-libre}
_localversionname=-libre-pae
@@ -54,6 +56,9 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
+ # #41458 fix hwmon for compal-laptop module
+ patch -p1 -i "${srcdir}/compal-laptop-hwmon-fix.patch"
+
cat "${srcdir}/config" > ./.config # simpler
if [ "${_kernelname}" != "" ]; then