summaryrefslogtreecommitdiff
path: root/cross/cross-newlib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cross/cross-newlib/PKGBUILD')
-rw-r--r--cross/cross-newlib/PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/cross/cross-newlib/PKGBUILD b/cross/cross-newlib/PKGBUILD
index 3cdb570b9..cf0020c51 100644
--- a/cross/cross-newlib/PKGBUILD
+++ b/cross/cross-newlib/PKGBUILD
@@ -102,7 +102,7 @@ url='http://www.sourceware.org/newlib/'
license=(BSD)
makedepends=($_target-gcc)
options=(!emptydirs !strip)
-source=(ftp://sourceware.org/pub/newlib/newlib-$_upstream_ver.tar.gz)
+source=(https://sourceware.org/pub/newlib/newlib-$_upstream_ver.tar.gz)
sha256sums=('fb4fa1cc21e9060719208300a61420e4089d6de6ef59cf533b57fe74801d102a')
build() {
@@ -113,10 +113,12 @@ build() {
../newlib-$_upstream_ver/configure \
--target=$_target \
--prefix=/usr \
- --disable-newlib-supplied-syscalls \
- --disable-nls \
--enable-newlib-io-long-long \
- --enable-newlib-register-fini
+ --enable-newlib-io-c99-formats \
+ --enable-newlib-register-fini \
+ --enable-newlib-retargetable-locking \
+ --disable-newlib-supplied-syscalls \
+ --disable-nls
make
}