summaryrefslogtreecommitdiff
path: root/cross/cross-binutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cross/cross-binutils/PKGBUILD')
-rw-r--r--cross/cross-binutils/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/cross/cross-binutils/PKGBUILD b/cross/cross-binutils/PKGBUILD
index cc6465502..c54fb7c4d 100644
--- a/cross/cross-binutils/PKGBUILD
+++ b/cross/cross-binutils/PKGBUILD
@@ -67,6 +67,23 @@
# @ : bin/sys (Only sh4 and sh4l support)
# < : experimental support. (future)
+#--------------------------------------------------------------------------------
+# Choosing the correct pkgdesc
+#--------------------------------------------------------------------------------
+# You must know wether your toolchain is a bare-metal one, if it's specifically for big-endian or
+# little-endian order and know its full name, if possible. Here are some useful tips:
+#
+# * If the toolchain has no operating system (see the toolchain triplet, <_os_target>), then it's a
+# bare-metal toolchain, in which case you have to specify it in the pkgdesc
+#
+# * Do a bit of research in forums, wikis and documents about the target you plan to build, a good
+# idea is to see the description that other distros put (e.g. Debian) if they have the same toolchain
+#
+# Example: arm-linux-gnueabi-{gcc,binutils,$etc}
+# This toolchain has GNU/Linux as OS, so it's not a bare-metal one. It's for armel, which
+# stands for "ARM EABI little-endian", but the gnueabi part means it uses the GNU EABI. You can find
+# that info in Debian's gcc-arm-linux-gnueabi and a couple of FLOSS and programmers community forums.
+
# Toolchain triplet: <_arch>-<machine>-<_os_target>
# <machine> is generally optional and uneeded
_target=x86_64-pc-linux-gnu