summaryrefslogtreecommitdiff
path: root/~lukeshu/holo-lukeshu/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-01-29 14:37:06 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2018-01-29 14:43:40 -0500
commite9a7b115824a97a1f50eba9152b35f7d0b930ec4 (patch)
treef50d7ff292b1a505e0994f6437b34f3e68f6b23d /~lukeshu/holo-lukeshu/PKGBUILD
parent060f824053bb33b0efd160de4c1d40bef785a700 (diff)
downloadabslibre-e9a7b115824a97a1f50eba9152b35f7d0b930ec4.tar.gz
abslibre-e9a7b115824a97a1f50eba9152b35f7d0b930ec4.tar.bz2
abslibre-e9a7b115824a97a1f50eba9152b35f7d0b930ec4.zip
mv ~lukeshu/holo{-lukeshu,}
Diffstat (limited to '~lukeshu/holo-lukeshu/PKGBUILD')
-rw-r--r--~lukeshu/holo-lukeshu/PKGBUILD70
1 files changed, 0 insertions, 70 deletions
diff --git a/~lukeshu/holo-lukeshu/PKGBUILD b/~lukeshu/holo-lukeshu/PKGBUILD
deleted file mode 100644
index 81953acef..000000000
--- a/~lukeshu/holo-lukeshu/PKGBUILD
+++ /dev/null
@@ -1,70 +0,0 @@
-# Maintainer (AUR): Stefan Majewsky <majewsky@gmx.net>
-# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
-
-# Upstream info
-_pkgname='holo'
-_pkgver=2.2
-_pkgdesc='Minimalistic configuration management'
-url='http://holocm.org'
-license=('GPL3')
-
-# patch info
-pkgname=$_pkgname-lukeshu
-pkgver=$_pkgver.lukeshu1
-pkgdesc="$_pkgdesc (with patches from lukeshu)"
-_gitver='commit=ec2b9a5a3d2d3384a84ed45dbc38eb689003e835'
-mksource=("$_pkgname-$pkgver::git+https://github.com/lukeshu/holo#$_gitver")
-mkmd5sums=('SKIP')
-provides=("$_pkgname=$pkgver")
-conflicts=("$_pkgname")
-
-# package info
-pkgrel=2.1
-arch=('i686' 'x86_64' 'armv7h')
-depends=()
-optdepends=(
- 'git: to display diffs of entities'
- 'openssh: for the holo-ssh-keys plugin'
- 'shadow: for the holo-users-groups plugin'
-)
-makedepends=('go' 'perl')
-checkdepends=('git' 'openssh')
-provides=(
- "holo=${pkgver}"
- # required for holo-build packages that have a holo-$PLUGIN dependency when there are files below /usr/share/holo/$PLUGIN/
- "holo-files=${pkgver}"
- "holo-run-scripts=${pkgver}"
- "holo-ssh-keys=${pkgver}"
- "holo-users-groups=${pkgver}"
-)
-conflicts=(
- 'holo-run-scripts'
- 'holo-ssh-keys'
- 'holo-users-groups'
-)
-backup=(
- 'etc/holorc'
- 'etc/holorc.d/10-files'
- 'etc/holorc.d/20-users-groups'
- 'etc/holorc.d/25-ssh-keys'
- 'etc/holorc.d/95-holo-run-scripts'
-)
-source=("https://repo.parabola.nu/other/~lukeshu/holo/$_pkgname-$pkgver.tar.gz")
-sha256sums=('ad64d5af1b08a6ec0053fe9a729052152d3f77c8488f791cc99cee5c12faf72d')
-
-options=('!strip') # binaries are already stripped inside the Makefile
-
-build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make
-}
-
-check() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make check
-}
-
-package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make install DESTDIR="${pkgdir}"
-}