summaryrefslogtreecommitdiff
path: root/~fauno/ruby-mustache/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-10-13 16:10:32 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-10-13 16:10:32 -0300
commit5b7a5a65a83bad0f88ae3b7384af3a5f79e4fc21 (patch)
tree503676f528ab510143684bc9ad6f4ed22b5a71f6 /~fauno/ruby-mustache/PKGBUILD
parent144a82822742596f18c1f9ce936e940fa893fafb (diff)
downloadabslibre-5b7a5a65a83bad0f88ae3b7384af3a5f79e4fc21.tar.gz
abslibre-5b7a5a65a83bad0f88ae3b7384af3a5f79e4fc21.tar.bz2
abslibre-5b7a5a65a83bad0f88ae3b7384af3a5f79e4fc21.zip
~fauno/ruby-mustache-0.99.4-1
Diffstat (limited to '~fauno/ruby-mustache/PKGBUILD')
-rw-r--r--~fauno/ruby-mustache/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/~fauno/ruby-mustache/PKGBUILD b/~fauno/ruby-mustache/PKGBUILD
new file mode 100644
index 000000000..7b396434c
--- /dev/null
+++ b/~fauno/ruby-mustache/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: David Campbell <davekong@archlinux.us>
+pkgname=ruby-mustache
+pkgver=0.99.4
+pkgrel=1
+pkgdesc="A framework-agnostic way to render logic-free views."
+arch=('any')
+url="http://github.com/defunkt/mustache"
+license=(MIT)
+depends=('ruby')
+makedepends=('rubygems')
+source=("http://gems.rubyforge.org/gems/mustache-${pkgver}.gem")
+noextract=("mustache-${pkgver}.gem")
+
+build() {
+ cd $srcdir
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies -i "$pkgdir$_gemdir" mustache-$pkgver.gem \
+ -n "$pkgdir/usr/bin"
+
+ install -Dm644 $pkgdir/usr/lib/ruby/gems/1.9.1/gems/mustache-$pkgver/LICENSE \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 $pkgdir/usr/lib/ruby/gems/1.9.1/gems/mustache-$pkgver/man/mustache.1 \
+ $pkgdir/usr/share/man/man1/mustache.1
+ install -Dm644 $pkgdir/usr/lib/ruby/gems/1.9.1/gems/mustache-$pkgver/man/mustache.5 \
+ $pkgdir/usr/share/man/man5/mustache.5
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('650194ec2c166feb087377647414b9dc')