summaryrefslogtreecommitdiff
path: root/~emulatorman/raider/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-03-10 23:09:06 -0200
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-03-10 23:09:06 -0200
commitf05c044a472c04a260e72f5cd6fd23ba681a84c2 (patch)
treed8922d6c7778db504acc2feca10e0bbfef801e8c /~emulatorman/raider/PKGBUILD
parent2386e0d74a9406d00dbbbab84a0e97a276fcf4b7 (diff)
downloadabslibre-f05c044a472c04a260e72f5cd6fd23ba681a84c2.tar.gz
abslibre-f05c044a472c04a260e72f5cd6fd23ba681a84c2.tar.bz2
abslibre-f05c044a472c04a260e72f5cd6fd23ba681a84c2.zip
~emulatorman/raider
Diffstat (limited to '~emulatorman/raider/PKGBUILD')
-rw-r--r--~emulatorman/raider/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/~emulatorman/raider/PKGBUILD b/~emulatorman/raider/PKGBUILD
new file mode 100644
index 000000000..960164820
--- /dev/null
+++ b/~emulatorman/raider/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: M.Carreira <arch@carreira.com.pt>
+# Contributor: M.Carreira <arch@carreira.com.pt>
+# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
+pkgname=raider
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Converts a single linux system disk in to a software raid 1, 4, 5, 6 or 10"
+arch=('any')
+url="http://sourceforge.net/projects/raider/"
+license=('GPL2')
+changelog=ChangeLog
+depends=('mdadm>=2.6' 'parted>=2.0' 'bash>=3.0' 'coreutils' 'util-linux' 'hdparm' 'cpio' 'inetutils')
+install=INSTALL
+
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('9150128c1cd5c58709aa0a5dd0e4c6b0')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d ${pkgdir}/usr/lib/raider
+ install -d ${pkgdir}/usr/sbin
+ install -m 755 -t ${pkgdir}/usr/lib/raider src/lib/*
+ install -p -o 0 -g 0 -m 755 src/sbin/raider ${pkgdir}/usr/sbin
+ install -p -o 0 -g 0 -m 755 src/sbin/raiderl ${pkgdir}/usr/sbin
+ install -p -o 0 -g 0 -m 755 src/sbin/raiderld ${pkgdir}/usr/sbin
+ install -d ${pkgdir}/var/lib/raider
+ install -d ${pkgdir}/var/log/raider -m 777
+ DOCDIR_INST=${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
+ install -d ${DOCDIR_INST}
+ install -m 644 AUTHORS COPYING ChangeLog FAQ INSTALL README TODO ${DOCDIR_INST}
+}
+
+# vim:set ts=2 sw=2 et: