summaryrefslogtreecommitdiff
path: root/pcr/trytond/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-02-14 12:13:51 -0200
committerMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-02-14 12:13:51 -0200
commitf67b20d8da80cc120dcfea0d3405de74a8e5f84a (patch)
tree2d57e7cdc4772adc20017980fda13f1267cfc127 /pcr/trytond/PKGBUILD
parent327433a2a7ae50151dcf0e6f6840a3eb5c065808 (diff)
parent9e33e61c00e3da5565b47e16b6618ab98c9ea38f (diff)
downloadabslibre-f67b20d8da80cc120dcfea0d3405de74a8e5f84a.tar.gz
abslibre-f67b20d8da80cc120dcfea0d3405de74a8e5f84a.tar.bz2
abslibre-f67b20d8da80cc120dcfea0d3405de74a8e5f84a.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/trytond/PKGBUILD')
-rw-r--r--pcr/trytond/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/pcr/trytond/PKGBUILD b/pcr/trytond/PKGBUILD
new file mode 100644
index 000000000..b270df368
--- /dev/null
+++ b/pcr/trytond/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Florian Walch <florian.walch@gmx.at>
+# Maintainer: Robin Baumgartner <robin@baumgartners.ch>
+pkgname=trytond
+pkgver=2.6.3
+_pkgdir=2.6
+pkgrel=1
+pkgdesc="A three-tiers high-level general purpose application platform (server application)"
+arch=('any')
+url="http://www.tryton.org/"
+license=('GPL3')
+depends=('python2>=2.4' 'python-lxml' 'python2-egenix-mx-base' 'python2-relatorio>=0.2.0' 'python2-genshi>=0.5' 'python2-polib')
+optdepends=('python-psycopg2: support for PostgreSQL database'
+ 'python-pywebdav: support for WebDAV feature'
+ 'pydot: support for displaying workflow graphs'
+ 'python-pytz: timezone support'
+ 'pyopenssl: support for SSL connection')
+makedepends=('python2-distribute')
+install="trytond.install"
+source=("http://downloads.tryton.org/$_pkgdir/$pkgname-$pkgver.tar.gz"
+ 'trytond.install'
+ 'trytond.service')
+md5sums=('0dd81769fc18fe2d20e83de4f17cb10d'
+ '768e68c01cb5913e36ea89c67fc98038'
+ 'b1535a8528dfd8f655624bf6faea6985')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ python2 setup.py install --root=$pkgdir
+ install -D -m644 etc/trytond.conf $pkgdir/etc/trytond.conf
+ install -D -m755 $srcdir/trytond.service $pkgdir/usr/lib/systemd/system/trytond.service
+}