summaryrefslogtreecommitdiff
path: root/pcr/tox-git/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2015-05-05 17:41:32 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2015-05-05 17:41:32 -0500
commit622fd5d8456c277f10830387f6123d150f0e7b36 (patch)
tree65c8791a29af435c674946b71b2a9078962013bf /pcr/tox-git/PKGBUILD
parente439ff9d9454a1c2a992dd3d8c550a9a14c4cfa1 (diff)
downloadabslibre-622fd5d8456c277f10830387f6123d150f0e7b36.tar.gz
abslibre-622fd5d8456c277f10830387f6123d150f0e7b36.tar.bz2
abslibre-622fd5d8456c277f10830387f6123d150f0e7b36.zip
tox-git-r3350.6a1efc3-1: updating version
Diffstat (limited to 'pcr/tox-git/PKGBUILD')
-rw-r--r--pcr/tox-git/PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/pcr/tox-git/PKGBUILD b/pcr/tox-git/PKGBUILD
index 87b89b34a..8cc742a40 100644
--- a/pcr/tox-git/PKGBUILD
+++ b/pcr/tox-git/PKGBUILD
@@ -1,25 +1,30 @@
# Maintainer: freaj <freaj@riseup.net>
-# Maintainer (Arch): Kevin MacMartin <prurigro at gmail dot com>
-# Contributor (Arch): Boohbah <boohbah at gmail.com>
-# Contributor (Arch): naxuroqa <naxuroqa at gmail.com>
+# Contributor (AUR): HÃ¥vard Pettersson <mail@haavard.me>
+# Contributor (AUR): naxuroqa <naxuroqa at gmail.com>
+# Contributor (AUR): Boohbah <boohbah at gmail.com>
+# Contributor (AUR): Kevin MacMartin <prurigro at gmail dot com>
_pkgname=tox
-pkgname=$_pkgname-git
-pkgver=r3349.422e744
+pkgname=tox-git
+pkgver=r3350.6a1efc3
pkgrel=1
pkgdesc='Secure, configuration-free, P2P Skype replacement backend'
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64')
url='https://tox.im'
license=('GPL3')
-depends=('libsodium' 'opus' 'libvpx')
+depends=(
+ 'libconfig>=1.4'
+ 'libsodium>=1.0'
+ 'libvpx'
+ 'opus'
+)
makedepends=('git' 'check')
-optdepends=('qtox-git: qt-based frontend'
- 'utox-git: lightweight tox client'
- 'toxic-git: ncurses-based frontend')
+optdepends=('qtox-git: qt-based Tox client'
+ 'utox-git: lightweight Tox client'
+ 'toxic-git: ncurses-based Tox client')
conflicts=("$_pkgname")
provides=("$_pkgname")
replaces=("$_pkgname")
-
source=("$_pkgname::git+https://github.com/irungentoo/toxcore.git")
sha512sums=('SKIP')
@@ -30,11 +35,11 @@ pkgver() {
build() {
cd $_pkgname
- ./autogen.sh
+ autoreconf -if
./configure \
--prefix=/usr \
--enable-daemon \
- --enable-ntox \
+ --disable-ntox \
--disable-tests
make
}
@@ -47,4 +52,5 @@ check() {
package() {
cd $_pkgname
make DESTDIR="$pkgdir" install
+ install -Dm644 ./other/bootstrap_daemon/tox-bootstrapd.service "$pkgdir/usr/lib/systemd/system/tox-bootstrapd.service"
}