summaryrefslogtreecommitdiff
path: root/pcr/tahoe-lafs/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2014-12-22 09:40:59 -0300
committerNicolás Reynolds <fauno@endefensadelsl.org>2014-12-22 10:06:23 -0300
commita1a812593f4cd2a80e9725c928184ed95275cf35 (patch)
treec8c1a14545c57807d4e82961442a373ca5ebf335 /pcr/tahoe-lafs/PKGBUILD
parent3f6441ae46acbd6ccf113159a52d5b00c4fd6a4e (diff)
downloadabslibre-a1a812593f4cd2a80e9725c928184ed95275cf35.tar.gz
abslibre-a1a812593f4cd2a80e9725c928184ed95275cf35.tar.bz2
abslibre-a1a812593f4cd2a80e9725c928184ed95275cf35.zip
patched tahoe
Diffstat (limited to 'pcr/tahoe-lafs/PKGBUILD')
-rw-r--r--pcr/tahoe-lafs/PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/pcr/tahoe-lafs/PKGBUILD b/pcr/tahoe-lafs/PKGBUILD
index e47b3b05e..a9937ba82 100644
--- a/pcr/tahoe-lafs/PKGBUILD
+++ b/pcr/tahoe-lafs/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor (Arch): Nicolas Pouillard <nicolas.pouillard@gmail.com>
pkgname=tahoe-lafs
pkgver=1.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="a secure, decentralized, fault-tolerant filesystem"
arch=('any')
url='http://tahoe-lafs.org/'
@@ -12,13 +12,21 @@ depends=('net-tools' 'python2' 'python2-zope-interface>=3.6.5'
'twisted' 'python2-pyasn1' 'python2-crypto' 'pycryptopp' 'nevow'
'python2-foolscap' 'python2-simplejson' 'zfec' 'python2-pyopenssl'
'pyutil' 'python2-argparse' 'zbase32' 'python2-mock>=0.8.0')
-source=(nodaemon.patch https://tahoe-lafs.org/source/tahoe-lafs/releases/allmydata-tahoe-$pkgver.tar.bz2)
+source=(nodaemon.patch
+ 0001-auto_deps-Workaround-dep-resolution-issue.patch
+ https://tahoe-lafs.org/source/tahoe-lafs/releases/allmydata-tahoe-$pkgver.tar.bz2)
sha256sums=('7fb13a50bdca729b9c78f12369e56fccf55594b646bddb270d55c08c83ce3449'
+ '055079c36e58a604765312eeb98df4133c77634bdb9a88da5a8c0142ea9e4e10'
'9c5516700fe95fdf8c57eca1e2a7b4aebf2de9a4d327d50afd684ebf833ccfe2')
-build(){
+prepare() {
cd "$srcdir/allmydata-tahoe-$pkgver"
patch -p0 < ../nodaemon.patch
+ patch -p1 < ../0001-auto_deps-Workaround-dep-resolution-issue.patch
+}
+
+build(){
+ cd "$srcdir/allmydata-tahoe-$pkgver"
python2 setup.py build
# disabled due to the nodaemon patch and the test_filesystem* tests
#python2 setup.py test || return 1