summaryrefslogtreecommitdiff
path: root/pcr/reicast-git/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2015-08-23 22:25:37 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2015-08-28 18:37:18 -0300
commite6535c873331a54a21435d8e9450b09a596a6874 (patch)
tree32ae5f05f8dcb9be8316db81251295b351753903 /pcr/reicast-git/PKGBUILD
parent2c37cc178227a3956f82e1b2b589824028c3d269 (diff)
downloadabslibre-e6535c873331a54a21435d8e9450b09a596a6874.tar.gz
abslibre-e6535c873331a54a21435d8e9450b09a596a6874.tar.bz2
abslibre-e6535c873331a54a21435d8e9450b09a596a6874.zip
pcr/reicast{,-multilib}-git
Diffstat (limited to 'pcr/reicast-git/PKGBUILD')
-rw-r--r--pcr/reicast-git/PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/pcr/reicast-git/PKGBUILD b/pcr/reicast-git/PKGBUILD
index e10d00c34..ddd9099e1 100644
--- a/pcr/reicast-git/PKGBUILD
+++ b/pcr/reicast-git/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Márcio Silva <coadde@parabola.nu>
pkgname=reicast-git
-pkgver=r1322.4b94e2f
+pkgver=r1546.5fd66a1
pkgrel=1
pkgdesc="A multiplatform Sega Dreamcast emulator"
arch=('i686' 'x86_64')
@@ -12,15 +12,15 @@ license=('GPL2')
conflicts=('reicast')
provides=('reicast')
makedepends=('git')
-depends=('libgl' 'alsa-plugins')
+depends=('libgl' 'alsa-plugins' 'libpulse')
optdepends=('xboxdrv: Userspace gamepad driver for Xbox and Xbox360 gamepads'
'antimicro: Graphical program used to map keyboard keys and mouse controls to gamepad buttons')
source=(reicast::"git+https://github.com/reicast/reicast-emulator.git"
- 'enable_joystick_support.patch'
+ 'enable_x11_keyboard_support.patch'
'wait_if_two_frames_already_in_flight.patch')
sha256sums=('SKIP'
- '464946512ca4cffac104128a85dd174520caeaa0325afbf281b6cfdbc0120fc6'
- 'f4d3b4ad7703da09dc59cae839ca225e1a21b89d905ede3519bf3174b40903da')
+ '095961538c13208b39ebb0b9d6b6e30c1225f218dcc67239a9d938a23aec601e'
+ '8f7b392ac6fac2d62e078a397f6b7c29ac3a23877d5c1a4566a58710b3383aef')
pkgver() {
cd reicast
@@ -29,20 +29,21 @@ pkgver() {
prepare () {
cd reicast
- patch -Np1 -i "$srcdir"/enable_joystick_support.patch
+ patch -Np1 -i "$srcdir"/enable_x11_keyboard_support.patch
patch -Np1 -i "$srcdir"/wait_if_two_frames_already_in_flight.patch
- # Fix pointer size on 64 bit arch: http://github.com/reicast-emulator/pull/768
- sed -i 's|verify((int)rbi);|verify((size_t)rbi);|' core/hw/sh4/dyna/driver.cpp
# Add experimental shadow support: http://github.com/reicast-emulator/issues/94
sed -i 's|//DrawModVols|DrawModVols|' core/rend/gles/gldraw.cpp
+
+ # Fix Xbox Input Axis
+ sed -i 's|DC_AXIS_LT, 0, 0, DC_AXIS_RT|0, 0, DC_AXIS_RT, DC_AXIS_LT|' core/linux-dist/joystick.cpp
+
+ # Enable Pulseaudio
+ sed -i 's|#USE_PULSEAUDIO|USE_PULSEAUDIO|' shell/linux/Makefile
}
build () {
make -C reicast/shell/linux
- if [[ $CARCH == x86_64 ]]; then
- make -C reicast/shell/linCPP
- fi
}
package () {
@@ -50,9 +51,5 @@ package () {
install -Dm755 shell/linux/reicast.elf "$pkgdir"/usr/bin/reicast
install -Dm755 shell/linux/nosym-reicast.elf "$pkgdir"/usr/bin/reicast-nosym
- if [[ $CARCH == x86_64 ]]; then
- install -Dm755 shell/linCPP/reicast.elf "$pkgdir"/usr/bin/reicast-cpp
- install -Dm755 shell/linCPP/nosym-reicast.elf "$pkgdir"/usr/bin/reicast-nosym-cpp
- fi
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}