summaryrefslogtreecommitdiff
path: root/pcr/qemu-user-static-git/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-03-20 14:09:46 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-03-20 14:10:47 +0100
commitb9afff56b2651322de7ea23792fb9daef478c219 (patch)
treeec8837d813b0bcb848ff7b1b8768acb63cf6fa73 /pcr/qemu-user-static-git/PKGBUILD
parent4727766b35ea63837841da6dccaa0a4ae5ad634e (diff)
downloadabslibre-b9afff56b2651322de7ea23792fb9daef478c219.tar.gz
abslibre-b9afff56b2651322de7ea23792fb9daef478c219.tar.bz2
abslibre-b9afff56b2651322de7ea23792fb9daef478c219.zip
pcr/qemu-user-static-git: updated to v2.11.0.r2577.gc26ef39204
Diffstat (limited to 'pcr/qemu-user-static-git/PKGBUILD')
-rw-r--r--pcr/qemu-user-static-git/PKGBUILD34
1 files changed, 5 insertions, 29 deletions
diff --git a/pcr/qemu-user-static-git/PKGBUILD b/pcr/qemu-user-static-git/PKGBUILD
index a16fa8ebc..7761b79c9 100644
--- a/pcr/qemu-user-static-git/PKGBUILD
+++ b/pcr/qemu-user-static-git/PKGBUILD
@@ -7,34 +7,16 @@ _pkgbase=qemu-git
_gitname=qemu
pkgname=(qemu-user-static-git qemu-user-static-binfmt-git)
pkgdesc="A generic and open source machine emulator and virtualizer. Git version."
-pkgver=2.11.50.r59752.fb5fff1588
+pkgver=v2.11.0.r2577.gc26ef39204
pkgrel=1
arch=(x86_64)
license=(GPL2 LGPL2.1)
url="http://wiki.qemu.org/"
makedepends=(git pixman-static glib2-static pcre-static python2)
source=(git://git.qemu.org/qemu.git
- 0001-linux-user-Use-if-to-only-call-validate_guest_space-.patch
- 0002-linux-user-Rename-validate_guest_space-init_guest_co.patch
- 0003-linux-user-init_guest_space-Clean-up-if-we-can-t-ini.patch
- 0004-linux-user-init_guest_space-Correctly-handle-guest_s.patch
- 0005-linux-user-init_guest_space-Clarify-page-alignment-l.patch
- 0006-linux-user-init_guest_commpage-Add-a-comment-about-s.patch
- 0007-linux-user-init_guest_space-Clean-up-control-flow-a-.patch
- 0008-linux-user-init_guest_space-Don-t-try-to-align-if-we.patch
- 0009-linux-user-init_guest_space-Add-a-comment-about-sear.patch
- 0010-linux-user-init_guest_space-Try-to-make-ARM-space-co.patch)
+ 0001-fix-program-invocation-name.patch)
sha256sums=('SKIP'
- '9953a8debd9456adb4f5968817fa89da4d4542e44980a5533ccf86371d819845'
- 'a977e9295daa14a9c73258cf16399eb5af66382217f8a4e69951ec044131a7ce'
- 'dba2cfeb24841d45936091319957ee6f65e481da3c761791d410d3b8e6799998'
- '75b3bda6752c4bf17488489f898767b6772b10ecc5d1f0a5bc1bd831e99a31e3'
- '731895a8ed6f6d322bb60764b01cf09e0ea762d7d53fc01e91c2d2aecfdc8844'
- '69b37040f52ef86b86c7c2952eb3f85f3c67d7adf289c43fdac8c71827c6e5b9'
- '76f88850b0f52450eecb80029ffe16db6f418cec3b58231aca354cc20bbfb16a'
- '76944d84990cc76e47c381849c683a346c5234bcebbe4c24334d0fd8368482db'
- '7845867348fd380def28c7fe023e54cee8ff88cd6754aae3ab3472149cfbde51'
- '1953e7cac58c23526d007d8559410e0042d4a7c1b8cbd5f4c0543f7f876436dd')
+ '85a1554cd9ce73f8f7eb8e9dd3cdb884466b4cfed7d28ede62246b46bea932cb')
validpgpkeys=('CEACC9E15534EBABB82D3FA03353C9CEF108B584')
case $CARCH in
@@ -44,8 +26,7 @@ esac
pkgver() {
cd "${srcdir}/${_gitname}"
-
- printf "%s.r%s.%s" "$(cat VERSION)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -55,12 +36,7 @@ prepare() {
cd "${srcdir}/${_gitname}"
sed -i 's/vte-2\.90/vte-2.91/g' configure
- # https://bugs.launchpad.net/qemu/+bug/1740219
- # https://lists.nongnu.org/archive/html/qemu-devel/2017-12/msg05237.html
- local patchfile
- for patchfile in ../????-linux-user-*.patch; do
- patch -p1 < "$patchfile"
- done
+ patch -Np1 -i "$srcdir"/0001-fix-program-invocation-name.patch
# update git submodules
scripts/git-submodule.sh update ui/keycodemapdb dtc