summaryrefslogtreecommitdiff
path: root/pcr/python-xattr/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-12-31 17:29:39 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-12-31 17:29:39 -0300
commit6f102d1647580e0bb9513c124b26a64c77da4f15 (patch)
tree0340f1f588be251183fe2b251bdba778f2c85c22 /pcr/python-xattr/PKGBUILD
parent433900b14f11dc9ee55b72e8e5946bf47f65b636 (diff)
parentb6cb10de275cea63bab0bee2a98342afa4fdc4ee (diff)
downloadabslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.tar.gz
abslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.tar.bz2
abslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.zip
Merge branch 'master' of ssh://gparabola/srv/git/abslibre
Diffstat (limited to 'pcr/python-xattr/PKGBUILD')
-rw-r--r--pcr/python-xattr/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/pcr/python-xattr/PKGBUILD b/pcr/python-xattr/PKGBUILD
new file mode 100644
index 000000000..d6977f435
--- /dev/null
+++ b/pcr/python-xattr/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.IO>
+
+pkgname=python-xattr
+pkgver=20111028
+pkgrel=1
+pkgdesc="module for manipulating filesystem extended attributes"
+arch=('i686' 'x86_64')
+url="http://undefined.org/python/#xattr"
+license=('MIT')
+conflicts=('pyattr')
+provied=('pyattr')
+makedepends=('setuptools')
+depends=('python2' 'git')
+
+_gitroot=https://github.com/xattr/xattr.git
+_gitname=xattr
+
+build() {
+ cd $srcdir/
+
+ if [ -e ${_gitname} ] ; then
+ cd ${_gitname}
+ git pull
+ cd ..
+ else
+ git clone ${_gitroot} ${_gitname}
+ fi
+
+ cd $srcdir/xattr/
+ python2 setup.py install --prefix=/usr --root=$pkgdir
+}