summaryrefslogtreecommitdiff
path: root/pcr/python-repoze.lru/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-12-31 17:29:39 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-12-31 17:29:39 -0300
commit6f102d1647580e0bb9513c124b26a64c77da4f15 (patch)
tree0340f1f588be251183fe2b251bdba778f2c85c22 /pcr/python-repoze.lru/PKGBUILD
parent433900b14f11dc9ee55b72e8e5946bf47f65b636 (diff)
parentb6cb10de275cea63bab0bee2a98342afa4fdc4ee (diff)
downloadabslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.tar.gz
abslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.tar.bz2
abslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.zip
Merge branch 'master' of ssh://gparabola/srv/git/abslibre
Diffstat (limited to 'pcr/python-repoze.lru/PKGBUILD')
-rw-r--r--pcr/python-repoze.lru/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/pcr/python-repoze.lru/PKGBUILD b/pcr/python-repoze.lru/PKGBUILD
new file mode 100644
index 000000000..844658c27
--- /dev/null
+++ b/pcr/python-repoze.lru/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: speps <speps at aur dot archlinux dot org>
+# Contributor: DasIch <dasdasich@googlemail.com>
+# Maintainer : Paraobla GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.IO>
+
+_name=repoze.lru
+pkgname=python-$_name
+pkgver=0.6
+pkgrel=1
+pkgdesc="A tiny LRU cache implementation and decorator"
+arch=('any')
+license=('custom:BSD')
+url="http://pypi.python.org/pypi/$_name"
+depends=('python')
+makedepends=('python-distribute')
+provides=(python-repoze-lru)
+conflicts=(python-repoze-lru)
+replaces=(python-repoze-lru)
+source=("http://pypi.python.org/packages/source/r/$_name/$_name-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/"
+
+ # license
+ install -Dm644 LICENSE.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}