summaryrefslogtreecommitdiff
path: root/pcr/polkit-elogind/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2018-04-19 22:11:23 -0300
committerDavid P <megver83@parabola.nu>2018-04-19 22:14:13 -0300
commit0dde27a0f3fd11a8d3195faedf2dd08193b0d425 (patch)
treed8e43a68218c1197302e9b10fed1435c81111a7a /pcr/polkit-elogind/PKGBUILD
parent1ca15343a97e3cf701b405ed92d6db85960333eb (diff)
downloadabslibre-0dde27a0f3fd11a8d3195faedf2dd08193b0d425.tar.gz
abslibre-0dde27a0f3fd11a8d3195faedf2dd08193b0d425.tar.bz2
abslibre-0dde27a0f3fd11a8d3195faedf2dd08193b0d425.zip
upgpkg: pcr/polkit-elogind 0.114-1.parabola1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'pcr/polkit-elogind/PKGBUILD')
-rw-r--r--pcr/polkit-elogind/PKGBUILD88
1 files changed, 40 insertions, 48 deletions
diff --git a/pcr/polkit-elogind/PKGBUILD b/pcr/polkit-elogind/PKGBUILD
index bb520fea4..e15f9a97e 100644
--- a/pcr/polkit-elogind/PKGBUILD
+++ b/pcr/polkit-elogind/PKGBUILD
@@ -1,77 +1,69 @@
-# Maintainer (Artix): artoo <artoo@manjaro.org>
-# Contributor (Arch): kozec <kozec at kozec.com>
-# Contributor (Arch): Lukas Jirkovsky <l.jirkovsky@gmail.com>
-# Contributor (Arch): Jan de Groot <jgc@archlinux.org>
+# Maintainer: David P. <megver83@parabola.nu>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_pkgname=polkit
pkgname=polkit-elogind
-pkgver=0.113+34+g29ba7af
-pkgrel=1
-pkgdesc="PolyciKit with elogind support for non-systemd systems"
-arch=('i686' 'x86_64' 'armv7h')
-url="http://www.freedesktop.org/wiki/Software/polkit"
-license=('LGPL')
-provides=("polkit=$pkgver")
-depends=('glib2' 'pam' 'expat' 'js' 'elogind')
-makedepends=('intltool' 'gtk-doc' 'gobject-introspection' 'git' 'autoconf-archive' 'libelogind')
+_pkgname=${pkgname/-elogind}
+pkgver=0.114
+pkgrel=1.parabola1
+pkgdesc="Application development toolkit for controlling system-wide privileges, with libelogind support"
+arch=(x86_64 i686 armv7h)
+license=(LGPL)
+provides=("$_pkgname=$pkgver")
+url="https://www.freedesktop.org/wiki/Software/polkit/"
+depends=(glib2 pam expat elogind js52)
+makedepends=(intltool gtk-doc gobject-introspection git autoconf-archive)
conflicts=('polkit' 'polkit-consolekit')
-#replaces=('polkit-consolekit')
-options=('!libtool')
-_commit=29ba7afba1b79a325183a71966f35926dfdf506e # master
-#source=("http://www.freedesktop.org/software/polkit/releases/$_pkgname-$pkgver.tar.gz")
+replaces=('polkit-consolekit')
+_commit=ed06baed179166389d536420a6fc532781d48178 # tags/0.114^0
source=("git+https://anongit.freedesktop.org/git/polkit#commit=$_commit"
'99-parabola.rules'
- 'polkit-0.114-elogind.patch')
+ 'elogind-configure-fix.patch')
sha256sums=('SKIP'
'd28d6ecaf7682860e2b3768bb266bd94313546b7cd0ef3c2eace7b1576c47adb'
- 'e5eb83a8922f1540309ce5884c4bd40b2972aa75778da945e2392501961a860b')
+ 'd90b2a95aa3e9e1ebf9369c038c144e04900e095c5405bc4ba4901c31bf3f59b')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/+/g'
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd $_pkgname #-$pkgver
- patch -Np 1 -i "${srcdir}"/polkit-0.114-elogind.patch
- NOCONFIGURE=1 ./autogen.sh
+ cd $_pkgname
+ git cherry-pick -n 373705b35e7f6c7dc83de5e0a3ce11ecd15d0409
+ patch -Np 1 -i ${srcdir}/elogind-configure-fix.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd $_pkgname #-$pkgver
+ cd $_pkgname
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --sbindir=/usr/bin \
- --localstatedir=/var \
- --libexecdir=/usr/lib \
- --enable-libsystemd-login=no \
- --enable-libelogind=yes \
- --disable-static \
- --enable-gtk-doc \
- --with-authfw=pam \
- --with-os-type=gentoo
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --libexecdir=/usr/lib \
+ --enable-libsystemd-login=no --disable-static \
+ --enable-gtk-doc --with-os-type=redhat \
+ --enable-libelogind=yes --with-systemdsystemunitdir=no
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
}
check() {
- cd $_pkgname #-$pkgver
- make -k check || :
+ cd $_pkgname
+ make -k check || :
}
package() {
- cd $_pkgname #-$pkgver
- make DESTDIR="$pkgdir" install
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
- chown root:102 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
- chmod 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
- install -m0644 "${srcdir}"/99-parabola.rules "${pkgdir}"/etc/polkit-1/rules.d
+ install -d -o root -g 102 -m 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
- install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf" <<END
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$_pkgname.conf" <<END
u polkitd 102 "PolicyKit daemon"
m polkitd proc
END
+ install -m0644 "${srcdir}"/99-parabola.rules "${pkgdir}"/etc/polkit-1/rules.d
}
+
+# vim: ts=2 sw=2 et: