summaryrefslogtreecommitdiff
path: root/pcr/phc-intel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2022-04-06 19:45:37 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2022-04-12 01:03:19 -0400
commit8144b256315765a54169b04c16ffd47c6f4213a2 (patch)
tree9ac8aeaedc5c6f5e2bf444b22ad0ae766facd9ce /pcr/phc-intel/PKGBUILD
parentf66887ec1352fc77e21efdeef796fd6825dc90e3 (diff)
downloadabslibre-8144b256315765a54169b04c16ffd47c6f4213a2.tar.gz
abslibre-8144b256315765a54169b04c16ffd47c6f4213a2.tar.bz2
abslibre-8144b256315765a54169b04c16ffd47c6f4213a2.zip
[phc-intel]: add package
Diffstat (limited to 'pcr/phc-intel/PKGBUILD')
-rw-r--r--pcr/phc-intel/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/pcr/phc-intel/PKGBUILD b/pcr/phc-intel/PKGBUILD
new file mode 100644
index 000000000..1882257c3
--- /dev/null
+++ b/pcr/phc-intel/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer (aur): adrien1018 <adrien.sf.wu[at]gmail[dot]com>
+# Contributor: fs4000 <matthias_dienstbier[at]yahoo[dot]de>
+# Contributor: trapanator <trap[at]trapanator[dot]com>
+# Contributor: tomprogrammer <Thomas-Bahn[at]gmx[dot]net>
+# Maintainer: Wael Karram <wael@waelk.tech>
+
+pkgname=phc-intel
+_phcver=0.3.2
+pkgver=$_phcver.12.41
+pkgrel=1
+pkgdesc="Frequency driver for Intel CPUs with undervolting feature"
+pkgdesc+=", (for Core/Core2 systems)"
+url="https://gitlab.com/linux-phc/phc-intel"
+arch=('any')
+arch=('x86_64' 'i686') # avoid publishing to non-x86 arches
+license=('GPL')
+depends=('dkms')
+# provides=('linux-phc') # useless - no arch, parabola, nor AUR package refers to this
+backup=('etc/default/phc-intel')
+_commit_hash='c0879a65d2687aaddc2b3ea630020e53ae0bc7cf'
+source=("https://gitlab.com/linux-phc/phc-intel/-/archive/$_commit_hash/phc-intel-$_commit_hash.tar.gz"
+ phc-intel.{default,sh,sleep,system-sleep} dkms.conf)
+sha256sums=('52275f7c6880a220983d9541f01e7b3f70d2cd95eadb854e7b77e4c005c3c09e'
+ 'ce08a5a4107be1d5723f1f169d515e67b6c77893f3994fc2d0d2ccf611307ed3'
+ 'b526f3e8e66f6495531f13f2e6867d3a07b2ec7a7c3b8aa061f22be1cd6e770f'
+ '569b85988cb38380fec85c25688b76abc24a46601aa8f58eb24eaebf863eebef'
+ '2e17c90d7bfae8f5070e46388e95d443188eaa7beb5ffdd418a0da090f2e7557'
+ '7b44882a96eeb7c79dbb7fe5b1ff8cded68c2b6a374c95bdc5e08c414cfd3549')
+
+prepare() {
+ cd $pkgname-$_commit_hash
+ sed -i 's,/sbin/modprobe phc-intel |,/sbin/modprobe phc-intel \&\& /usr/bin/phc-intel set |,' phc-intel.modprobe
+}
+
+package() {
+ umask 022
+ install -Dm644 dkms.conf "$pkgdir/usr/src/phc-intel-$_phcver/dkms.conf"
+ install -Dm644 phc-intel.default "$pkgdir/etc/default/phc-intel"
+ install -Dm755 phc-intel.sh "$pkgdir/usr/bin/phc-intel"
+ install -Dm755 phc-intel.sleep "$pkgdir/usr/lib/pm-utils/sleep.d/00phc-intel"
+ install -Dm755 phc-intel.system-sleep "$pkgdir/usr/lib/systemd/system-sleep/phc-intel"
+
+ cd $pkgname-$_commit_hash
+ install -Dm644 phc-intel.modprobe "$pkgdir/usr/lib/modprobe.d/phc-intel.conf"
+ cp -R inc Makefile "$pkgdir/usr/src/phc-intel-$_phcver/"
+}