summaryrefslogtreecommitdiff
path: root/pcr/perl-text-glob/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2015-05-01 07:25:13 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2015-05-01 07:48:22 -0300
commit9eae6cb6bf3ce37a2a711dfe9625e5ebf0df2a77 (patch)
tree402078d4eb71b560bcbacd7cf96fab2321050406 /pcr/perl-text-glob/PKGBUILD
parent0c8378e3f99b3739c39a8ff3d0ba55e069e95950 (diff)
downloadabslibre-9eae6cb6bf3ce37a2a711dfe9625e5ebf0df2a77.tar.gz
abslibre-9eae6cb6bf3ce37a2a711dfe9625e5ebf0df2a77.tar.bz2
abslibre-9eae6cb6bf3ce37a2a711dfe9625e5ebf0df2a77.zip
perl-text-glob: fix syntax
Diffstat (limited to 'pcr/perl-text-glob/PKGBUILD')
-rw-r--r--pcr/perl-text-glob/PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/pcr/perl-text-glob/PKGBUILD b/pcr/perl-text-glob/PKGBUILD
index c9b20d67c..02d9ccc6d 100644
--- a/pcr/perl-text-glob/PKGBUILD
+++ b/pcr/perl-text-glob/PKGBUILD
@@ -17,7 +17,7 @@ url='http://search.cpan.org/dist/Text-Glob'
source=("http://search.cpan.org/CPAN/authors/id/R/RC/RCLAMP/Text-Glob-$pkgver.tar.gz")
md5sums=('1daa10e087f891c49b720a5c551a024b')
sha512sums=('9b729e4ece88ad79e1b637c7f35e5e1ecae3fd7f62c408ed4f3fcac2e8e8afff32d7d805e1b0269800aada5ae609d03335d42ac54def2797d301e91fa488ae47')
-_distdir="${srcdir}/Text-Glob-$pkgver"
+_distdir="Text-Glob-$pkgver"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -26,21 +26,21 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$_distdir"
+ cd $srcdir/"$_distdir"
/usr/bin/perl Build.PL
/usr/bin/perl Build
)
}
check() {
- cd "$_distdir"
+ cd $srcdir/"$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
/usr/bin/perl Build test
)
}
package() {
- cd "$_distdir"
+ cd $srcdir/"$_distdir"
/usr/bin/perl Build install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}