summaryrefslogtreecommitdiff
path: root/pcr/pandoc-static/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2015-04-18 09:36:53 -0300
committerNicolás Reynolds <fauno@endefensadelsl.org>2015-04-18 09:38:51 -0300
commitf0d0f6e6c63a55b8ebfc7de2b3ba930970945489 (patch)
treeb37a07a422ecca21a1e3fe9c0d83eff95a08a887 /pcr/pandoc-static/PKGBUILD
parent5075361afc8a19799e5313510610ad413ff058e0 (diff)
downloadabslibre-f0d0f6e6c63a55b8ebfc7de2b3ba930970945489.tar.gz
abslibre-f0d0f6e6c63a55b8ebfc7de2b3ba930970945489.tar.bz2
abslibre-f0d0f6e6c63a55b8ebfc7de2b3ba930970945489.zip
pandoc-static: less patching
Diffstat (limited to 'pcr/pandoc-static/PKGBUILD')
-rw-r--r--pcr/pandoc-static/PKGBUILD31
1 files changed, 8 insertions, 23 deletions
diff --git a/pcr/pandoc-static/PKGBUILD b/pcr/pandoc-static/PKGBUILD
index ab6c69af7..771917b90 100644
--- a/pcr/pandoc-static/PKGBUILD
+++ b/pcr/pandoc-static/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pandoc-static
_pkgname=pandoc
pkgver=1.13.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='Conversion between markup formats (no Haskell libraries)'
url='http://johnmacfarlane.net/pandoc/'
license=('GPL')
@@ -18,12 +18,10 @@ depends=('icu>=55' 'icu<56' 'gmp' 'libffi' 'zlib')
makedepends=('ghc' 'sh' 'cabal-install' 'alex' 'happy')
optdepends=('texlive-most: for PDF creation')
options=(strip !makeflags !distcc !emptydirs)
-source=(https://repo.parabola.nu/other/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig}
- pandoc-citeproc-ghc-7.10.patch)
+source=(https://repo.parabola.nu/other/${pkgname}/${pkgname}-${pkgver}-${pkgrel}.tar.xz{,.sig})
validpgpkeys=('49F707A1CB366C580E625B3C456032D717A4CD9C')
-sha512sums=('614832f1c96bbdd67a50c8ace76f416d87b9dfeb873a7b2de6d8336a1804f68c53e5460ad62c49097fd8ea052f38a1f66163bc56cc808ac18bc57ce76063ecbc'
- 'SKIP'
- '22339e9b3dc68151fdf867379bc3b9f600cb5e08b45a26ab755a3d0d2034b461763174d82468fe9f3d6bd8a4a14b1ce30b4ab040c44777f8b99e89915fb4b4ee')
+sha512sums=('1368894ff2382a4b5e5461dbc70e7267635a9cf44e2b0b6d4fef7c70556060920e447f9254a9af9ef1c983ba9360116e463299d4d5ec12a08f6f48dde6b26c2e'
+ 'SKIP')
declare -gA _flags
_flags[pandoc]='https make-pandoc-man-pages'
@@ -44,17 +42,14 @@ mksource() (
cd $pkgname-$pkgver
cabal update
- cabal fetch "${_packages[@]}"
# Get the build order
cabal install --dry-run \
--flags="embed_data_files ${_flags[*]}" \
- "${_packages[@]}" > BUILDORDER
+ "${_packages[@]}" \
+ | sed -rn 's/(\S*[0-9]+).*/\1/p' >BUILDORDER
- # Place all of the downloaded sources in the target directory
- for file in ../.cabal/packages/*/*/*/*.tar.?z; do
- bsdtar xf "$file"
- done
+ cabal get $(cat BUILDORDER)
)
prepare() {
@@ -63,16 +58,6 @@ prepare() {
find "${srcdir}/${pkgname}-${pkgver}/${_pkgname}-${pkgver}" \
-name default.latex \
-exec sed "/fontenc/d" -i {} \;
-
- # https://github.com/hvr/deepseq-generics/issues/2
- sed "s/\(ghc-prim >= 0.2 && < \)0.4/\10.5/" -i \
- "${srcdir}/${pkgname}-${pkgver}/deepseq-generics-0.1.1.2/deepseq-generics.cabal"
-
- sed "s/\(base <4.\)8/\19/" -i \
- "${srcdir}/${pkgname}-${pkgver}/split-0.2.2/split.cabal"
-
- pushd "${srcdir}/${pkgname}-${pkgver}/pandoc-citeproc-0.6/"
- patch -Np1 -i "${srcdir}/pandoc-citeproc-ghc-7.10.patch"
}
build() (
@@ -114,7 +99,7 @@ build() (
;;
esac
popd >/dev/null
- done < <(sed -rn 's/(\S*[0-9]+).*/\1/p' BUILDORDER)
+ done < BUILDORDER
)
package() {