summaryrefslogtreecommitdiff
path: root/pcr/newlisp/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@parabola.nu>2013-01-16 14:55:14 -0300
committerNicolás Reynolds <fauno@parabola.nu>2013-01-16 14:55:14 -0300
commit937c8656ecd59d9800c7d6dfb23a816195320bdd (patch)
tree98a52492045c0b59661676ee6289a9419b8a2072 /pcr/newlisp/PKGBUILD
parent4446f2330756577653fd2ebbaf1bef6950720fde (diff)
parentf62179b3bfcd584fa856098cbddb39614b9f8a60 (diff)
downloadabslibre-937c8656ecd59d9800c7d6dfb23a816195320bdd.tar.gz
abslibre-937c8656ecd59d9800c7d6dfb23a816195320bdd.tar.bz2
abslibre-937c8656ecd59d9800c7d6dfb23a816195320bdd.zip
Merge branch 'master' of ssh://gparabola/srv/git/abslibre
Diffstat (limited to 'pcr/newlisp/PKGBUILD')
-rw-r--r--pcr/newlisp/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/pcr/newlisp/PKGBUILD b/pcr/newlisp/PKGBUILD
new file mode 100644
index 000000000..a53106390
--- /dev/null
+++ b/pcr/newlisp/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: scrawler <scrawler@gmail.com>
+# Maintainer : Parabola GNU / Linux-libre Aurélien DESBRIÈRES <aurelien@cwb.IO>
+
+pkgname=newlisp
+pkgver=10.4.5
+pkgrel=1
+pkgdesc="newLISP is a LISP like, general purpose scripting language."
+url="http://www.newlisp.org"
+license=('GPL')
+arch=('x86_64' 'i686')
+depends=('readline')
+optdepends=('openjdk6')
+options=('docs')
+source=(http://newlisp.org/downloads/$pkgname-$pkgver.tgz)
+install=$pkgname.install
+
+build() {
+cd $srcdir/$pkgname-$pkgver
+./configure
+[ $CARCH = "x86_64" ] && make -f makefile_linuxLP64_utf8
+[ $CARCH = "i686" ] && make -f makefile_linux_utf8
+install -d $pkgdir/usr/bin
+install -d $pkgdir/usr/share/man/man1
+make bindir=$pkgdir/usr/bin mandir=$pkgdir/usr/share/man \
+datadir=$pkgdir/usr/share install
+}