summaryrefslogtreecommitdiff
path: root/pcr/mosquitto/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-04-30 22:11:43 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-04-30 22:11:43 -0300
commitcecbbd66b56e9fb6b8bc11dc68dfe3e2917df4b1 (patch)
tree09c74cded6685bfc85e6360344f9c0ea46035553 /pcr/mosquitto/PKGBUILD
parent5624115d5d725beed89b8e52460a4b1026a93ef9 (diff)
parente11d86778598365a4d4881125144138449b1af12 (diff)
downloadabslibre-cecbbd66b56e9fb6b8bc11dc68dfe3e2917df4b1.tar.gz
abslibre-cecbbd66b56e9fb6b8bc11dc68dfe3e2917df4b1.tar.bz2
abslibre-cecbbd66b56e9fb6b8bc11dc68dfe3e2917df4b1.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/mosquitto/PKGBUILD')
-rw-r--r--pcr/mosquitto/PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/pcr/mosquitto/PKGBUILD b/pcr/mosquitto/PKGBUILD
index 0a7209f0b..652e75691 100644
--- a/pcr/mosquitto/PKGBUILD
+++ b/pcr/mosquitto/PKGBUILD
@@ -1,23 +1,24 @@
# This is the PKGBUILD for mosquitto, an MQTT broker and example clients
-# Maintainer: Dan Anderson <dan-anderson@cox.net>
-# Contributor: Gordon JC Pearce <gordon@gjcp.net>
+# Maintainer: Alexander Rust <mail at alr dot st>
+# Contributor: Dan Anderson <dan-anderson at cox dptnet>
pkgname=mosquitto
-pkgver=1.1
-pkgrel=1
-pkgdesc="An MQTT broker and clients"
-arch=(i686 x86_64 mips64el)
+pkgver=1.1.3
+pkgrel=2
+pkgdesc="An Open Source MQTT v3.1 Broker"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'mips64el')
url="http://mosquitto.org/"
makedepends=('python')
optdepends=('python: python support')
license=('BSD')
-source=(http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz{,.asc})
-md5sums=('ab51f64eb3f0041402073aa7865f3ec4'
- '76fbc38a2eb0b8110caf7ac1f43d4057')
+source=(http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz{,.asc} "$pkgname.service" )
+md5sums=('fd0cae17221d778b0a002c31e6c3de9e'
+ 'SKIP'
+ 'b7cdd7a65d9a7ac5a8c2456f4b1f2d8f')
build() {
cd "$srcdir/$pkgname-$pkgver"
-# Remove hardcoded prefix
+ #Remove hardcoded prefix
find -name Makefile -exec sed '/prefix=/d' -i {} \;
make prefix=/usr
@@ -26,7 +27,11 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
make prefix=/usr DESTDIR="$pkgdir/" install
-
+
+ # Systemd service file
+ install -Dm644 $srcdir/$pkgname.service $pkgdir/usr/lib/systemd/system/$pkgname.service
+
+ # License files
install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
install -Dm644 LICENSE-3rd-party.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE-3rd-party
}