summaryrefslogtreecommitdiff
path: root/pcr/mosquitto/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-01-02 16:04:44 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-01-02 16:04:44 -0200
commit1bf5038b88434788f223abbfe4d40711980662f8 (patch)
tree820b68fff118e27405a8265e929539f133183a42 /pcr/mosquitto/PKGBUILD
parent018aa5ccf0a2fdd350d7cfe2f2022e4ed8290429 (diff)
parent593a1335dd0bb92ac9f1e2a7a2ca12b3b3f06cd5 (diff)
downloadabslibre-1bf5038b88434788f223abbfe4d40711980662f8.tar.gz
abslibre-1bf5038b88434788f223abbfe4d40711980662f8.tar.bz2
abslibre-1bf5038b88434788f223abbfe4d40711980662f8.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/mosquitto/PKGBUILD')
-rw-r--r--pcr/mosquitto/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/pcr/mosquitto/PKGBUILD b/pcr/mosquitto/PKGBUILD
new file mode 100644
index 000000000..0a7209f0b
--- /dev/null
+++ b/pcr/mosquitto/PKGBUILD
@@ -0,0 +1,34 @@
+# This is the PKGBUILD for mosquitto, an MQTT broker and example clients
+# Maintainer: Dan Anderson <dan-anderson@cox.net>
+# Contributor: Gordon JC Pearce <gordon@gjcp.net>
+
+pkgname=mosquitto
+pkgver=1.1
+pkgrel=1
+pkgdesc="An MQTT broker and clients"
+arch=(i686 x86_64 mips64el)
+url="http://mosquitto.org/"
+makedepends=('python')
+optdepends=('python: python support')
+license=('BSD')
+source=(http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz{,.asc})
+md5sums=('ab51f64eb3f0041402073aa7865f3ec4'
+ '76fbc38a2eb0b8110caf7ac1f43d4057')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+# Remove hardcoded prefix
+ find -name Makefile -exec sed '/prefix=/d' -i {} \;
+
+ make prefix=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir/" install
+
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE-3rd-party.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE-3rd-party
+}
+
+# vim:set ts=2 sw=2 et: