summaryrefslogtreecommitdiff
path: root/pcr/imagemagick-srv/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-06-30 20:39:50 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-06-30 20:39:50 -0400
commitfab493b2e4893382a91050101c622dc3cc6e81b4 (patch)
treedbb7c61eac560dd198ec429ee1798b6de5e58502 /pcr/imagemagick-srv/PKGBUILD
parent6e46f0d41e83c2cfad8b3a21348ebc3bfb0c9594 (diff)
downloadabslibre-fab493b2e4893382a91050101c622dc3cc6e81b4.tar.gz
abslibre-fab493b2e4893382a91050101c622dc3cc6e81b4.tar.bz2
abslibre-fab493b2e4893382a91050101c622dc3cc6e81b4.zip
Update pcr/imagemagick-srv as pcr/imagemagick-nox
Diffstat (limited to 'pcr/imagemagick-srv/PKGBUILD')
-rw-r--r--pcr/imagemagick-srv/PKGBUILD84
1 files changed, 0 insertions, 84 deletions
diff --git a/pcr/imagemagick-srv/PKGBUILD b/pcr/imagemagick-srv/PKGBUILD
deleted file mode 100644
index 68cd9e607..000000000
--- a/pcr/imagemagick-srv/PKGBUILD
+++ /dev/null
@@ -1,84 +0,0 @@
-# $Id$
-# Maintainer (Arch): Eric Bélanger <eric@archlinux.org>
-# Maintainer: Márcio Silva <coadde@parabola.nu>
-
-pkgbase=imagemagick
-pkgname=imagemagick-srv
-pkgver=6.8.8.9
-pkgrel=1
-arch=('i686' 'x86_64' 'mips64el')
-url="http://www.imagemagick.org/"
-license=('custom')
-provides=("$pkgbase=$pkgver")
-conflicts=($pkgbase)
-makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript' \
- 'openexr' 'libwmf' 'librsvg' 'libxml2' 'jasper' 'liblqr' \
- 'libwebp') # libcl opencl-headers
-#source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
-source=(ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
- perlmagick.rpath.patch)
-sha1sums=('3ad2deadbc7e7c6e61eb5590fcc49d71fd96b247'
- 'SKIP'
- 'e143cf9d530fabf3b58023899b5cc544ba93daec')
-
-prepare() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- sed '/AC_PATH_XTRA/d' -i configure.ac
- autoreconf --force --install
- patch -p0 -i "${srcdir}/perlmagick.rpath.patch"
-}
-
-build() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- [[ $CARCH = "i686" ]] && EXTRAOPTS="--with-gcc-arch=i686"
- [[ $CARCH = "x86_64" ]] && EXTRAOPTS="--with-gcc-arch=x86-64"
- [[ $CARCH = "mips64el" ]] && EXTRAOPTS="--with-gcc-arch=mips64el"
- ./configure --prefix=/usr --sysconfdir=/etc --with-modules --disable-static \
- --disable-hdri --with-wmf --with-openexr --with-xml --with-lcms2 --with-jp2 \
- --with-webp --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
- --with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr --with-rsvg \
- --disable-opencl --without-gvc --without-djvu --without-autotrace \
- --without-jbig --without-fpx --without-dps --without-fftw $EXTRAOPTS
- make
-}
-
-#check() {
-# cd ImageMagick-${pkgver%.*}-${pkgver##*.}
-# make check
-#}
-
-package_imagemagick-srv() {
- pkgdesc="An image viewing/manipulation program (for web servers)"
- depends=('perl' 'libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr') # 'libcl')
- optdepends=('imagemagick-doc: for additional information'
- 'ghostscript: for Ghostscript support'
- 'openexr: for OpenEXR support'
- 'libwmf: for WMF support'
- 'librsvg: for SVG support'
- 'libxml2: for XML support'
- 'jasper: for JPEG-2000 support'
- 'libpng: for PNG support'
- 'libwebp: for WEBP support')
- backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
- "etc/ImageMagick-${pkgver%%.*}/colors.xml"
- "etc/ImageMagick-${pkgver%%.*}/delegates.xml"
- "etc/ImageMagick-${pkgver%%.*}/log.xml"
- "etc/ImageMagick-${pkgver%%.*}/magic.xml"
- "etc/ImageMagick-${pkgver%%.*}/mime.xml"
- "etc/ImageMagick-${pkgver%%.*}/policy.xml"
- "etc/ImageMagick-${pkgver%%.*}/quantization-table.xml"
- "etc/ImageMagick-${pkgver%%.*}/thresholds.xml"
- "etc/ImageMagick-${pkgver%%.*}/type.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-dejavu.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
- options=('!docs' 'libtool' '!emptydirs')
-
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- make -j1 DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick/LICENSE"
- install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick/NOTICE"
-
-#Cleaning
- rm -f "${pkgdir}"/usr/lib/*.la
-}