summaryrefslogtreecommitdiff
path: root/pcr/imagemagick-nox/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-10-05 14:51:50 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-10-05 14:51:50 -0500
commit4266b77925742ff8a6f06edf5d5b5c18573a2a7a (patch)
tree326e62bddf1289bdebd86c5ccd564cd0cf9f2cc2 /pcr/imagemagick-nox/PKGBUILD
parent37e594b6d87602df989a38f79476b9f8d83dd4e3 (diff)
downloadabslibre-4266b77925742ff8a6f06edf5d5b5c18573a2a7a.tar.gz
abslibre-4266b77925742ff8a6f06edf5d5b5c18573a2a7a.tar.bz2
abslibre-4266b77925742ff8a6f06edf5d5b5c18573a2a7a.zip
Removing imagemagick-nox
Diffstat (limited to 'pcr/imagemagick-nox/PKGBUILD')
-rw-r--r--pcr/imagemagick-nox/PKGBUILD120
1 files changed, 0 insertions, 120 deletions
diff --git a/pcr/imagemagick-nox/PKGBUILD b/pcr/imagemagick-nox/PKGBUILD
deleted file mode 100644
index a9409d42b..000000000
--- a/pcr/imagemagick-nox/PKGBUILD
+++ /dev/null
@@ -1,120 +0,0 @@
-# $Id$
-# Maintainer (Arch): Eric Bélanger <eric@archlinux.org>
-# Contributor: Márcio Silva <coadde@hyperbola.info>
-# Contributor: Luke Shumaker <lukeshu@parabola.nu>
-# Maintainer: Andreas Grapentin <andreas@grapentin.org>
-
-# parabola changes and rationale:
-# - adapted from extra/imagemagick
-# - building only imagemagick, without X11 and opencl support
-# - added provides and conflicts: imagemagick
-# - removed depends: libxt, libxext, libcl, opencl-icd-loader
-# - removed makedepends: libxt, libxext, opencl-headers, opencl-id-loader, libcl, glu
-
-pkgbase=imagemagick
-pkgname=(imagemagick-nox)
-pkgver=7.0.7.22
-pkgrel=1
-pkgdesc="An image viewing/manipulation program (without X11 support)"
-url="http://www.imagemagick.org/"
-arch=(x86_64 i686 armv7h)
-license=(custom)
-depends=(libltdl lcms2 fontconfig liblqr libraqm libpng)
-makedepends=(ghostscript openexr libwmf librsvg libxml2 openjpeg2 libraw libwebp
- chrpath ocl-icd ghostpcl ghostxps)
-checkdepends=(gsfonts ttf-dejavu)
-_relname=ImageMagick-${pkgver%%.*}
-_tarname=ImageMagick-${pkgver%.*}-${pkgver##*.}
-provides=("$pkgbase=$pkgver")
-conflicts=("$pkgbase")
-source=(https://www.imagemagick.org/download/$_tarname.tar.xz{,.asc}
- parabola-fonts.diff)
-sha256sums=('49de9e08ea255a1f939158d85d50dfa29285bccbdcb7fee0fe4309061d438489'
- 'SKIP'
- 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
-validpgpkeys=(D8272EF51DA223E4D05B466989AB63D48277377A) # Lexie Parsimoniae
-
-shopt -s extglob
-
-prepare() {
- mkdir -p binpkg/usr/lib/pkgconfig {binpkg,docpkg}/usr/share
-
- cd $_tarname
-
- # Fix up typemaps to match our packages, where possible
- patch -Np1 -i ../parabola-fonts.diff
-
- # Don't run auto(re)conf; assumes use of git
-}
-
-build() {
- cd $_tarname
-
- no_x=yes with_x=no \
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --with-dejavu-font-dir=/usr/share/fonts/TTF \
- --with-gs-font-dir=/usr/share/fonts/gsfonts \
- PSDelegate=/usr/bin/gs \
- XPSDelegate=/usr/bin/gxps \
- PCLDelegate=/usr/bin/gpcl6 \
- --enable-hdri \
- --disable-opencl \
- --with-gslib \
- --with-lqr \
- --with-modules \
- --with-openexr \
- --with-openjp2 \
- --with-perl \
- --with-perl-options=INSTALLDIRS=vendor \
- --with-rsvg \
- --with-webp \
- --with-wmf \
- --with-xml \
- --without-autotrace \
- --without-djvu \
- --without-dps \
- --without-fftw \
- --without-fpx \
- --without-gcc-arch \
- --without-gvc \
- --without-jbig
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
-}
-
-check() {
- cd $_tarname
- ulimit -n 4096
- make check
-}
-
-package_imagemagick-nox() {
- depends=("libmagick=$pkgver-$pkgrel")
- optdepends=('imagemagick-doc: manual and API docs')
- options=('!emptydirs')
-
- cd $_tarname
- make DESTDIR="$srcdir/binpkg" install
-
- mkdir -p "$pkgdir/usr/"{lib,share}
- mv "$srcdir/binpkg/usr/bin" "$pkgdir/usr/"
- mv "$srcdir/binpkg/usr/lib/perl5" "$pkgdir/usr/lib"
- mv "$srcdir/binpkg/usr/share/man" "$pkgdir/usr/share"
-
- # remove useless display
- rm -vf "$pkgdir/usr/bin/display"
-
- find "$pkgdir/usr/lib/perl5" -name '*.so' -exec chrpath -d {} +
-
-# template start; name=perl-binary-module-dependency; version=1;
-if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
- _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
- _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
- depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
-fi
-# template end;
-
- install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE NOTICE
-}